Play and Reply not working

Hi,

I created a course in Articulate Storyline 360.  The player properties for controls were set with seekbar checked for read-only and play/pause checked.  Slide triggers are set for "Jump to previous slide when user clicks previous" and the next button is disabled when the timeline starts but normal when the timeline ends for "Jump to next slide when user clicks next".  I published this for LMS as a SCORM 1.2 file and uploaded to our LMS.

When this is played in the LMS and I click the previous button, I'm returned to the end of the previous slide, and the play button and replay button do not cause the audio and video to replay for that slide.  The next button is disabled, so the only option is to exit and restart at the beginning of the course.

What am I missing?  Thanks! 

Kim

 

1 Reply
Judy Nollet

Hi, Kimberly,

OMG. Yes, one would expect that the trigger to disable NEXT when the timeline starts would not re-execute when the slide resumes its saved state. But it does. I was able to re-create that issue. 

I'm going to report this as a potential bug. In the meantime, you can fix the issue by using a variable and condition for each slide you're controlling this way.

  • Create a T/F variable with the initial value of False.
  • For the trigger that disables NEXT, add a condition so that only happens when the variable is False.
  • Also add a trigger that adjusts the variable to True when the timeline ends. 

Here's what your slide triggers would look like with a variable named "SlideDone": 

Here's a quicker option if you want the Next button disabled until the timeline ends for all of your slides. Go to the Menu settings in the Player, and use Restricted Navigation. Storyline will automatically disable NEXT the first time a user visits a slide. After the timeline ends, the NEXT button will enable and will stay that way.

Best regards,

- Judy