Play Media triggers duplicating for no reason in try mode screen recordings

Hi Community,

I have identified a strange phenomenon in my project(s): Whenever I have a step-by-step screen recording that I inserted in try mode in my course, and I publish said course, even if the action works fine on my computer the moment our marketing team uploads the course to our website (standard html page), the courses that include such exercises stop working at exactly the point when a hotspot needs to be clicked in the exercise that triggers the screen recording action to play. What I noticed when checking in storyline is that whenever I have these hotspots with said triggers, the triggers are duplicated for no reason. When I delete one of the triggers, both triggers disappear, when I create the trigger again, I will end up having the same trigger twice. There is no way around this and I am suspecting that this might be the cause why the triggers don't work in the published and uploaded course. I can send the storyline file upon request, but have added a screenshot. Maybe someone else has come across this?

13 Replies
Tim Ivanic

Hi Alyssa,

Unfortunately I already fixed the project where this occurred because we had to get everything published in time (I used different triggers - instead of play media and jump to next slide when media finishes I duplicated the slides and included the screen recording in the second one with a jump to next slide when user clicks in the first one - hope that wasn't too confusing). I will keep my eyes open for whenever this should recur and then post the project here - thanks for allowing me to share.

William Grove-Fanning

Tim says: "whenever I have these hotspots with said triggers, the triggers are duplicated for no reason. When I delete one of the triggers, both triggers disappear, when I create the trigger again, I will end up having the same trigger twice."

I experience this behavior off and on as well.  A workaround solution is to change the action for one of the two identical triggers (e.g., edit it), select OK, and then delete it. The other trigger is not deleted in the process of deleting the changed trigger.

Katie Riggio

Hello, William. Appreciate you working with our team!

Our Support Engineers are experts at troubleshooting issues like these. Confirming receipt of your project, and our team will delete it when they're done looking over it. Look out for a follow-up email shortly, and I'll follow the case along so I can share any relevant information here!

William Grove-Fanning

Heard back from Articulate. They say that it’s a known issue for Storyline 360 and has been logged as a possible software bug.

They provide a workaround that is better than the one I previously provided. When two triggers in the hotspot section are automatically generated, to delete one trigger without deleting the other, create or move a third trigger in between the duplicate Play media triggers. This will allow you to delete one trigger without affecting the other (see picture).

Hopefully this workaround helps others until a permanent fix is in place!