Player Navigation button for Quiz Review - Only "Submit" Available?

Greetings,

I recently upgraded to Storyline 2 and have found that courses created in Storyline 1 that contained a quiz review option now use the "Submit" button to advance through the review. Previously the player buttons were Next and Previous. Is there a way to make the quiz player use "Submit" to submit the user answers but when the user reviews the quiz (by selecting the option on the results page) to navigate the quiz review with the Next and Previous buttons in Storyline 2? This is an issue since it appears that using the "Submit" button to advance the quiz review also submits the answers again to the LMS.  

15 Replies
Sean Dugger

Hello Ashley,

What I have tested and repeated is that when upgrading a course that has a Review Quiz option Storyline, is that the Storyline backup file has the correct navigation (Next/Previous). However, the Storyline 2 file Quiz Review navigation is Submit and I am unsure how to get the correct navigation into the file. I have attached a converted file and the backup file which demonstrates this behavior.

Sean Dugger

Hi Ashley,

I just reviewed both files again and the file: EN_EU_FLA_AML_Assessment - SL1 Backup.story  has the correct pre/next navigation in the Quiz Review. This is the backup file that was created during the file upgrade to the Storyline 2 update. The Upgraded file is the one that has the incorrect navigation in the Quiz Review.

The Upgraded Storyline 2 file: EN_EU_FLA_AML_Assessment.story appears to have the submit button for navigation in the Quiz Review. This happened during the upgrade process. If you preview this file and then click Review Quiz at the Results slide you should see the same.

Please advise. 

Ashley Terwilliger

HI Sean,

Did you review the video I shared in my last post? The second part of that video shows me going through the upgraded  Storyline 2 file where the review quiz shows the prev/next buttons as expected. I tested it again this AM without deleting any of the questions, to take the full exam, and I still get the prev/next buttons to appear on the review. Can you confirm that you're working on local project files as described here and try to import the project into a new project as detailed here to see if that resolves any odd behavior you're seeing? 

Sean Dugger

Hi Ashley,

I may be missing something because you clearly can get it to work properly. I have attached a video of the backup version working then I go through the import process in SL2 and it shows Submit rather than the prev/next in preview. Please review and let me know what I am doing incorrectly.

Ashley Terwilliger

Hi Sean,

Thanks for the screen recording. The only thing that I saw that was different was you imported the file into SL2 instead of just choosing to open an SL1 file with SL2 and letting SL2 handle upgrading it. Can you try the latter and let me know if that changes the behavior? 

Also, from your video it doesn't look like the submit button is changing the value of the quiz or causing the slides to be reset, correct? 

Sean Dugger

Hi Ashley,

I have opened the SL1 files and let SL2 upgrade as well as import to SL2 from SL1. Additionally, after importing or allowing SL2 to upgrade I have gone to the results slide, deleted it, and then added a new results slide from scratch just to see if it would work. Unfortunately, it seems that does not help either. However, I have found that when building an entire quiz to results from scratch in SL2 the correct navigation in the review is present.

The Submit button would not change the answers since the settings are such that the user is just reviewing the quiz and not allowed to change their answer. What seems to be occurring when the course is on an LMS and the user reviews the quiz, it behaves as though the user is retaking the quiz and the submitted reviewed answers are logged/captured as if the user re-took the quiz when in actuality they were just reviewing. So a quiz that was taken only once but reviewed appears to have been taken twice with the exact same result. This is a problem since we are heavily regulated internally, domestically (US), and internationally, and a regulator could potentially ask to see the amount of attempts and scores of a user population at any time.

Please let me know if there is anything more I can do or if you have any other questions.

Paul DeHorn

Not sure If I should start a new post or tag on to this one... I'm having a very similar issue but I started the file in Storyline 2 and have the latest update (Update 4: 1500.717) installed.

In my situation, the SUBMIT button appears instead of the PREV/NEXT buttons only when its published to the LMS (our learning server) using AICC. When I preview in Storyline and publish to the Web the review quiz results pages have the previous and next buttons and everything works as designed. But the published version shows the Submit button instead and will only advance on an incorrect response. When I click Submit on a correct response, nothing happens and you can't navigate forward.

Paul DeHorn

Thanks Ashley. The issue was releated to the updates, but not on my computer. In my current gig, I send my story files to the Learning & Dev Group and they publish and post the courses. Its a long story (no pun intended)  why, but they weren't keeping current with the updates. So now they are current, and everything works as designed. Agian, I always seem to find an answer on E-Learning Heroes. Thanks.