Post CMI, Exit Suspend

Does anybody have any information regarding Articulate module post CMI, Exit Suspend status. Essentially, I am tracking down a random occurance involving SCORM 2004 modules and exit status for those modules. On occasion any given user may complete a module and the Exit status of that module will end up in Suspend mode instead of Normal or terminal mode. This means the user completed the course, is shown their score, but the system (Mzinga) still thinks the course is incomplete because it did not receive a terminal response from the module.

Any help or further discussion is greatly appreciated.

Jonathan Donley

Field 1 Post

17 Replies
Justin Grenier

Good Afternoon Jonathan, and welcome to Heroes!

When exiting a course, Storyline content will set cmi.exit to suspend 100% of the time. This is to allow the learner to resume a course (even a completed course) where they left off. If we were to set cmi.exit to normal upon completion, the learner's attempt would end.

Since it sounds like you are saying that your LMS doesn't always see these suspended attempts as incomplete, I would recommend enabling LMS Debug Mode so that you can take a closer look at the communication that is being sent back-and-forth between the content and the LMS. Perhaps this will help you to isolate why some learners (but not all) are incomplete.

Good luck with your project!

Jonathan Donley

Hello Justin,

Thank you for working with me on this situation. I may not have stated the case accurately based on your response.

1. My LMS does not roll up a completed course attempt when cmi.exit="suspend".
2. While in progress, the users exit status is set to "suspend". When the user completes the articulate course, it typically sends a cmi.exit="normal" which allows the LMS to roll up.
3. On a small percentage of user attempts, the cmi.exit does not get set to "normal" thus not letting the LMS do it's roll up.
4. The LMS seems to assume that every exit they send is suspend, and that they don't set a normal

Any thoughts?

Thank you,

Jonathan

Justin Grenier

Hello again, Jonathan.

I would recommend enabling LMS Debug Mode and sharing with us (1) a copy of your .story project file, (2) the resulting LMS Debug Log when Storyline appears to be setting cmi.exit to suspend and (3) the resulting LMS Debug Log when Storyline appears to be setting cmi.exit to normal.

We look forward to receiving your files for further troubleshooting. Thanks!

Anneke Garcia

Hi! I am having the same issue as the original poster, and am also using Mzinga. The course shows as complete, and for most users in the rollup the status is set to exit, but for a handful of users, the status remains in suspend.

Could this be happening if users are exiting without clicking the "Close Course" button that I've set to execute the "Exit course" trigger? Is it something as simple as that? Or with these other users, was there something happening in the SCORM transfer that was not marking these courses complete?

Ashley Terwilliger

Hi Anneke,

I can't speak to the specifics of Mzinga, but the exit course trigger has been known to cause some difficulty as detailed here. I'd also suggest referring to the answers and links Justin shared above for some additional information and detail about the exit course behavior as a whole.

Anneke Garcia

Thanks! I looked at that article, and that's not quite our issue - it's not that the exit course trigger isn't working. I'm just wondering whether the exit course trigger has anything to do with setting the cmi.exit in the SCORM.

I've been looking through the details above as well, and can understand why Storyline always reports cmi.exit as suspend, but my LMS administrator is telling me that courses won't roll up attempts with a suspend status. For the majority of users in the majority of our courses, though, which are published with Storyline's default SCORM 2004 settings, attempts roll up just fine, and so my assumption is that the majority of the time those attempts are being set to normal somewhere.

I'm currently looking at the debug logs and will match them with our next LMS report. I just wonder if there are any other Mzinga users who could report back on whether they've had any success in determining where those suspended attempts were coming from.

Ashley Terwilliger

Hi Annette,

What's the completion requirement you're using in addition to the set up? That should be what is also reported to the LMS to indicate that the user completed the course and an attempt. The suspend status is also there to assist with the resuming of the course, so perhaps instead you may also want to look at setting it to "never resume"? 

Winke Wieers

We are using Taleo Learn (Oracle) as LMS and facing the same problem. The first time the course is completed, the completion date and score is captured in our LMS, but the second time the completion date is mentioned as "last viewed date" and the new score is not captured.

Example: Simple Course
We are facing this problem only with Scorm 2004 courses (the Scorm 1.2 courses are working fine). Can anyone help us out? How can we also make our Scorm 2004 courses work like they should?
Of course we could republish them as Scorm 1.2 courses, but we have used these courses in recurring learning plans and pushed them to 9000 users, so if we have to republish all these courses, change all these learning plans and upload the historical data of all these courses again, this will be a hell of a job...

Attached: a simple course I created to reproduce the issue in our staging environment

Ashley Terwilliger

Hi Winke, 

It sounds like Taleo Learn (Oracle) may be keeping the course in Review mode once a learner has met the completion requirement. That setup allows a learner to access a course again to view it, but not make any changes to their score or completion status. There is a way you could modify this, take a look at the steps here! 

Winke Wieers

Hi Ashley,

Thanks for your answer.  I tried the following steps, but unfortunately it didn't solve our problem:
* Changed the value of the variable REVIEW_MODE_IS_READ_ONLY in the Configuration.js file to false in the folder on the FTP-server.


* Opened the existing course and completed it again.
* Checked the results in the user details => Still the same problem
* Uploaded the Scorm package once more in our LMS
* Opened this new course and completed it twice.
* Checked the results in the user details => Still the same problem: completion date is mentioned as "Last viewed date"

Did I miss something? Do I have to rezip the files before this change is working? We normally don't have to do that, we just overwrite the files on the FTP-server.