Preview Issue After Update 1

Hi,

I have been sailing along smoothly developing a new flash module in Storyline. Yesterday, I updated Storyline with Update 1 and have since been unable to preview my content. 

The preview loads initially, but as soon as I try to advance to the second scene, I get a huge exclamation mark and either have to close out of preview mode or restart Storyline. 

Again, I have never experienced behavior like this until the update yesterday.

I followed the "erratic behavior" Kbase article and re-installed Storyline, but the issue persists. 

On deadline, so would really appreciate some help getting this resolved. 

I am running my files from the C drive and am on a workstation with insane amounts of HD space and RAMM.

Thanks,

Renee

16 Replies
Christine Hendrickson

Hi Eilert,

I took a look at Renee's case for this issue and it looks like it was resolved.

  • First, make sure that you're working with content that is local. Work on your local drive (your C: drive). Working on a network drive or a USB drive can cause erratic behavior, including file corruption, loss of audio, and other unexpected behavior. 
  • Please take a look at this article, if you haven't already, and follow the steps provided for your operating system. Please try to replicate the issue once you finished repairing your software. 
  • Try to importing the contents to a new story file and see if you can still replicate the issue.

Here's how: 
1. Create a new Storyline file. 
2. Select Import > Storyline 
3. Browse for the existing file 
4. Import all the slides. 
5. Save with a different file name. 
6. Try to preview or publish. 

Eilert Torsnes

Hi Christine

Adrian was quick to respond and was very helpful! He wasn't able to replicate the issue, which lead him to believe that it was caused by the files location (server, of course...:S)

Hopefully that's it, if not I'll uninstall and repair as described in the article you mention.

I'm currently importing the story file into a new, locally stored story file, trying to see if that solves the problem:)

Thanks for all the input.

- Eilert

Eilert Torsnes

Repair didn't solve it, reinstall didn't solve it, importing the course to a new, locally stored storyfile didn't solve it...I'm presenting this prototype to the customer in three hours, will do the remaining troubleshooting and hopefully it will work...if not I'll just have to rebuild it from scratch in a hurry...

Eilert Torsnes

Completed the troubleshooting described the article you pointed me towards, but that didnt solve the problem. 

The story file consists of 6 slides, with 5 layers on each slide.

  • Each layer contains a video that starts from trigger (when user click a play icon), and a textbox. 
  • Deleted all the layers on two slides, same problem. 
  • Deleted all layers on all slides, problem gone.

Will try to rebuild the layers to see if it occurs again...

- Eilert

Eilert Torsnes

Hmmm....Ive rebuilt the layers for the first two slides...and the problem is back...could it be connected with how i build the course?

What I am building is a clickable prototype. I will describe how I did it in detail, and I've attached the story file. If anyone figures out why it crashes it would be highly appreciated.

  1. First I build the main slide, with custom navigation for five sub-slides
  2. Then i duplicate the main slide into five sub-slides, change the heading for each slide
  3. Then i create a layer for sub-slide 1. The layer consists of an example video and a textbox
  4. I duplicate the layer until I have five layers. The layers are displayed when user clicks subheadings on the slide
  5. Then i copy the content in the original layer on sub-slide 1 + create new layer on sub-slide 2 + paste the content from original layer into new layer
  6. Then I repeat step 4 and 5

I did this for sub-slide 1, tried previewing and it worked. Did it for sub-slide 2, previewed, clicked around a bit and it crashed. 

It seems to happen when switching really fast between the subslides...what I do is probably not "normal" user behavior, but one would expect Storyline to handle a fast clicker? And that it would take some time to load rather than crash? 

I've used custom arrows for navigation, custom states (glow around navigation-arrow) that indicate progress, and layers containing video, and I've copy pasted and duplicated slides, layers and content in order to work fast...are any of those things known to cause preview failure?

Any input as to how I can solve this matter will be appreciated

Eilert

Eilert Torsnes

I've rebuilt the entire course literally from scratch, with all the content and storyfile locally stored.

When previewing I get the same issue.

Tried deleting all layers and all videos, and the preview runs like it should.

Does this mean that storyline cant handle multiple videos in slides? Or could duplicating/copy pasting slides causes the problem? Ive inserted two examplevideos on ceveral slides/layers, could the repeated use cause this? Will a fast clicking user cause storyline to crash?

We're currently shooting ceveral vids intended for courses under construction, if we cant insert them without storyline crashing we're pretty much screwed...

- Eilert

Christine Hendrickson

Good morning Eilert,

I apologize for the delay in response and I'm very sorry to hear that you're still working with this. However, it would be best to communicate through your support case on this issue so we can continue to troubleshoot the problem with you. If you can, please respond to the last message you received or refer to your case (00306879) so Adrian will be aware that the problem still exists. This way he can work with you and try to resolve the issue as quickly as possible. Since you've taken a lot of additional troubleshooting steps since you last updated the case, you might want to mention this forum post so Adrian can see everything you've already tried to resolve the issue. 

Thanks!

Eilert Torsnes

Here we go again....

Considering I HAD to solve this issue I've put some time into building the course in a different way...instead of six six slides with five layers on each slide, I've created six scenes with six slides in each...same content, stored locally, but no layers....and previewing now works like a charm!

To the user the functionality will seem the same, which is most important:) 

But it takes waaaay longer time to build it that way, and the story view looks cluttered to say the least...

I guess we can say that the problem is worked around, but not solved. Without knowing exactly what went wrong, it seems that it evolved around the videos in layers.

My suggestion to others in a similar situation is to try to create ceveral identical slides rather than using layers to add additional content to one slide...timeconsuming to set up the navigation that way, but at least it works...

Any input on the capacity of layers will be appreciated:)

Justin Grenier

Good Morning Chris, and welcome to Heroes!

Could you try importing your content into a new file or performing a clean remove/reload of Storyline?