5 Replies
Helen Jones

In my case it is happening on one of my courses but not another.  I have copied the Notepad "information" from the error message pop-up box (several times).  Is something corrupting the file or is it a different issue?  This is the code message I sent to Articulate:

<?xml version="1.0" encoding="utf-16"?>
<ErrorReport xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <EmailAddress>helen.jones@vca.com</EmailAddress>
  <UserId>auth0|c8f5b5a0-dd5f-0132-c16a-22000b188b5e</UserId>
  <MachineName>USLAKLHJO1-L</MachineName>
  <HardwareId>T7SCS-NTP3D-3TVUU-4U01S</HardwareId>
  <Message>Specified argument was out of the range of valid values.
Parameter name: direction</Message>
  <StackTrace>   at PointF s.e(IAnimatable A_0, Direction A_1, bool A_2, int A_3)
   at bwPositionSegment af.g(IAnimatable A_0, Direction A_1)
   at bwPositionSegment af.h(IAnimatable A_0, Direction A_1)
   at bwTweenPosition af.u(IAnimatable A_0)
   at bwAnimation af.s(IAnimatable A_0)
   at void u.Animate(IAnimatable animatable)
   at string Articulate.Design.Animations.ShapeAnimations.b(bwStageObject A_0, string A_1, Nullable&lt;TimeSpan&gt; A_2)
   at void Articulate.Design.Shape.ai(bwStageObject A_0)
   at void Articulate.Design.Shape.Articulate.Player.IPlayerShape.AddAnimations(IPlayerService service, bwStageObject stageObj)
   at void Articulate.Player.PlayerContentPublisher.a(IEnumerable&lt;IPlayerShape&gt; A_0, bwSlideBase A_1)
   at bwSlide Articulate.Player.PlayerContentPublisher.CreateSlideObject(IPlayerSlide slide, bwISlideContainer sceneobj)
   at void Articulate.Player.PlayerContentPublisher.CreateBridgewaterSlide(PlayerWriterSettings settings, IPlayerSlide slide, bwISlideContainer sceneobj)
   at bool Articulate.Player.PlayerContentPublisher.CreateContentScenes(PlayerWriterSettings settings, IPlayerContentProvider contentProvider)
   at bwContent Articulate.Player.PlayerWriter.WriteContent(IPlayerContentProvider contentProvider)
   at bool Articulate.Player.PlayerWriter.Write(IPlayerContentProvider contentProvider)
   at void nr.n()
   at void Articulate.Design.Publish.TargetContext+PublishBackgroundWorker.OnDoWork(DoWorkEventArgs e)
   at void Articulate.ComponentModel.STABackgroundWorker.a(object A_0)</StackTrace>
</ErrorReport>

Helen Jones

To follow up with this, I did not have this issue with another course.  So I tried the preview mode, slide-by-slide in the one where I was having issues.  It all boiled down to 1 slide!  I saved a test copy of my course, and deleted the "offending" slide and the preview (by slide or by entire project) issue was resolved.  I then copied each object on the offending slide into a new slide (clicking Preview slide between each object) until I isolated the ONE SHAPE (one shape with one word) that caused the problem.  The rebuilt slide has not caused a problem.

I recommend doing the same process.  Every so often there is one slide that has to be rebuilt.  It was just odd that it showed up in the preview functions.

Best to you!