Previous Button disabled without reason

I am desperate for help! I have a course that previously worked fine. Today I opened it to check it prior to publishing it and putting it in our LMS, and now NONE of the previous buttons work in it. I have tried deleting the triggers and adding them back in. I have tried taking the previous button off of the player and putting it back.  Nothing seems to work.  The next button works fine. And the JWS shortcut navigation keys (Alt P) works to go to the previous slide.  However, the previous button is always grayed out.  Please help! File attached.

 

Thank you! 

15 Replies
Leslie McKerchie

Hi Emily,

Thanks for reaching out and sharing your .story project so that I could take a look at what was causing the reported behavior.

It looks like you have your navigation set to locked. Locked means learners can only view slides in the order you've designed. They can't jump ahead or skip over slides, nor can they go back to any previously viewed slides.

It sounds like restricted navigation may fit your needs better so that users can visit the previously viewed slides if needed.

Katie Riggio

Hey there, Emily!

I'm glad to hear that adjusting the navigation to Restricted did the trick. Let's explore the Alt+P and Alt+N keys!

Those two keyboard shortcuts don't ring a bell, but I'm curious if you're referring to what happens with them when under Slide navigation and gestures in Slide Properties or when using the 'When user presses a key' trigger.

It sounds like the former, but I tested both scenarios just in case: Here's a short video of my test.

Let me know, and we'll look at next steps from there!

Emily Webster

Hi Katie,

 

Thank you for the response and video! I am trying to use the "User presses a key" trigger and Alt N and Alt P to move from one slide to the next and to return to previous slide for our learners who use JAWS screen reader (for the visually impaired).   I am using Storyline 3 however, and not 360. 

I opened the file back up today, and it appears that the triggers are working in the preview "view". I will publish for the LMS and see if they work that way - could there be an issue between publishing it that would create the issue of those two user presses a key trigger within my LMS?

 

Thank you!

Emily Webster

So when I preview the scene it allows me to use the alt p/alt n to move from slide to slide.  However, when I publish it (for LMS) and then I view project, those press key triggers (alt p/alt n) do not work.  Any ideas?  I have tried publishing it to both a network drive and to my hard drive and get the same results.

Katie Riggio

Happy Friday, Emily. I appreciate you working with me on this!

I uploaded your course to SCORM Cloud, an industry-standard LMS testing tool, where I was able to navigate between slides with those keys in Chrome 79. Here's a recording of what I saw, and here's the link to the hosted output.

To help determine our next steps, could you try my output link and let me know if you run into the problem there? Also, what browser(s) are you using to view the published content?

Katie Riggio

Thanks for that detail and for trying that link, Emily!

I now see the same problem when testing the content in IE11, which matches an open issue for Storyline 3 where key press triggers do not work correctly in the Flash output.

As Flash begins its ride into the sunset, publishing the course for HTML5 only using Storyline 3 is the right move! Here's a link to the HTML5 only hosted output, where the keys should work correctly in IE11.

If there's anything else I can answer, I'll be here!