problem following validation of an interaction without any answer selected

Hi,

i use my own validate button in a multiple response interaction. Everything is ok for the cases correct / incorrect answer(s) but when the learner validate without having selected an answer, an automatic message is displayed (see the screenshot above). After this message whatever the answer validated by the learner, the audio file present in my "Correct" or "Incorrect" layer is not played but the rest of the timeline is played normally.

Someone can explain me what's occur ?

10 Replies
Ali Goulet

Hey Lucie! Thanks so much for sharing your project file here and allowing us to take a look. The issue you're seeing is one that's been reported to our Quality Assurance Team as a software bug. I really appreciate you reaching out here about it, and I went ahead and added this thread to the report. Since you're subscribed here, you'll receive updates as soon as they're available. Depending on priority and risk, some bugs can be fixed quickly, while others take longer to resolve. Here's some further information on how we identify and tackle bugs.

It does appear to be an issue only happening in the HTML5 output, so if you were to publish using the Flash option- the audio will play on the feedback layers even after users receive that message if they hit submit before selecting an answer. I did a quick test of that which you can view over here

If the HTML5 output is needed, another workaround would be to disable the "Submit" button when timeline starts. Then you can add another trigger to change the state of the "Submit" button back to Normal if the state of any of the check boxes is selected. That way users will not be able to click the "Submit" button without selecting an answer first and won't run into that message.

I've attached an edited version of your project file as an example of what I'm describing. Hope that's helpful for you, and thanks again for reaching out here about this. :) 

Ali Goulet

Great question, Lucie! You can set up a trigger for each of your drag objects to change the state of the submit button to "Normal" when the object is dropped. I made a quick (and adorable) example of this using a Free Form Drag & Drop which I've attached here. Let me know if that's helpful! 

Lucie Lemaitre

Ok, thanks for this information. It's important to know!

On the other hand is it possible to be informed personally when the bug will be resolved, do you think it will be solved quickly?

Because implementing these solutions is going to be very expensive in time for me (I have several quizzes with more than 10 questions of differents types each time ...)

Ali Goulet

Hey Lucie, I can definitely understand the concern here and the time constraints involved for those workarounds since you're working with so many quizzes. I've made sure that this thread has been included in our QA report for this issue and I'll be sure to update right here in a comment as soon as any further information is available. I don't have a specific timeline, but you'll be personally notified via email about any updates since you're subscribed to this thread. Thanks again for reporting this behavior here- the more impact we see for an issue the quicker the resolution will typically be, so reaching out here was the perfect move! :) 

Leslie McKerchie

Hi Lucie,

Good news! We fixed the issue you reported where:

Audio does not resume after clicking OK on a feedback layer when you hit submit before selecting an answer

Be sure to install the latest Storyline 360 update to take advantage of all the recent features and fixes. 

If the problem happens again, please record a Peek 360 screencast for me, and I'll be happy to help or you can always work directly with our support engineers here.