Problem with question banks

Hi can anyone help please?

I'm working in storyline 360 and have creating a course refresh. There are a number of modules in my course and because it's a refresh the learner gets asked one question (randomly selected from question bank of four) first. If they get it right they get a results page saying 'passed' and then move straight onto next module, and so on.

However, if they fail the question they have to read through the learn and at the end get taken back to the question bank from which they answer another randomly selected question. However, this second time the options are not selectable. And I can't work out why!?

14 Replies
Adam Zamczyk

Hi Wendy

I'm afraid neither has helped. I still l can't click into the the options, when I am returned to the question bank a second time. I have added 'reset results' to the results slide and have changed the questions from 'reset to intial state' to 'automatically decide' to the questions. Weirdly, the first module has always worked fine. It doesn't have a question bank but just one question and yet now I've been fiddling with the build, even that question isn't working now either.

I have attached the build file if you can see what on earth I've done!

Wendy Farmer

Hi Jo

I've got Mod 1 working but wanted to check with you about the other modules. If I fail on first attempt and read through the content, when i attempt a question the second time and get it correct do i still fail the module for not getting it right on the first attempt - that is what I am seeing in all the modules?  In some I get the answer correct on the second attempt, it tells me I failed but when I reach the final slide I have a white tick against that module?

Adam Zamczyk

Hi Wendy 

Firstly. no - if you fail a question on first attempt but correct on second attempt you should pass that module.

Both triggers are correct I'm just doing it differently each module. In Mod 2 I've set the 'mod2courseread' trigger on the slide in the learn as you will only see the learn if you got the answer wrong first time. This means that when you return to the results slide on getting the answer wrong again, you need to move onto next module.

In the later modules I used the same idea but had the trigger on the question, so that if the count (changing at 0.25 each time) goes to 0.5 then the learner has seen a question twice  and therefore needs to move onto next module.

They both seemed to work  - at one point anyway. 

Wendy Farmer

Hi Jo

I moved the reset results trigger to when the user clicks the hotspot instead of when the fail layer starts and it's allowing me to go back and answer another question.

However - Module 2 I got the first question incorrect on purpose - read the content, got the second question correct (with correct feedback popup) and then I get the you failed Module 2 layer move on.

I'll keep testing to see what happens at the end.

I got all questions correct for every module but I still receive the you failed this module layer but at the end I see this result