Problem with triggers on layers not working right

I'm having a problem with triggers on my layers not working right.  If I duplicate a layer and then go in and make some trigger changes on the new layer, the new triggers don't work right, they revert back to those on the "original" layer.  If I copy the entire new layer into a new slide, everything works right.  Any ideas or suggestions?  I suppose I can just stop using the layers feature but I'm hoping there is a better solution.  Additionally, a quiz that is marked as return to initial state when revisiting isn't resetting.  

16 Replies
Karan Dennis

I've made many "fixes" to get around the problems so unless there is a way to go back and retrieve prior work the only remaining problem is the quiz slide that won't reset to original state.  I will post that and hope for some feedback about what I'm doing wrong.  Another problem I had was audio tracks being inserted over other objects, meaning not given their own line on the timeline.  I cleared that problem by closing everything and rebooting my computer.  I really hope my computer isn't the problem!  Thanks so much!

Karan Dennis

Here's the whole thing.  The remaining problem is with the quiz question.  I solved the other one by deleting the chain link layer and adding it as a slide.  Thanks so much for taking a look.  Also, I found if I paused the base layer with a trigger on the the base layer, the audio on the new layer wouldn't play.  I got around that with a variable so the base layer wouldn't just continue if the viewer didn't click the magnifying glass.  

Karan Dennis

Please take a look at this slide.  I've isolated this slide so it's the only one I"m uploading.  All of the layers, ie. correct, and choice b and choice c are set as reset to initial state as well as the base layer, but they aren't doing it right.  I'm also uploading a snip of the setting.  

Veronica Budnikas

Do you mean that when I choose the incorrect answer and click TRY AGAIN, the slide is not resetting then? In other words, do you want the slide to reset when you click TRY AGAIN on the b or c layers?

If that is the case, then the trigger on the try again layers should be to Jump to THIS slide, rather than Hide layer. As it is, it doesn't reset because the user doesn't leave the slide, therefore it does not count as 'revisiting'.

You could also just have another trigger on layers b and c to change the state of all radio buttons to Normal.

Karan Dennis

I'm talking about all the radio buttons should be blank when revisiting.  I've added another quiz slide I developed recently that had no problems and I can't figure out the difference. If you take a look at slide 1.2 it does it correctly, so why doesn't 1.1?

Veronica Budnikas

Because 1.1 doesn't have the triggers required to turn the radio buttons back to Normal, like 1.2 has:

The problem here isn't "revisiting". The user is not revisiting the slide when they click Try again; they are only hiding the layer, so if you want something to change on the base layer, then you need triggers. Slide 1.2 has the correct triggers on the Try again layer. 1.1 should have those triggers on Choice C and Chuck Hint layers.