Problem with video on iPad, iPhone and Android

Hello,

For one of our course, we used MP4 video files to move the eyes and lips of our two characters. On computers, the animation works fine. When viewing the animation on iPad, iPhone and Android, there is a Play button that appears on the lips and eyes.


We have included in the triggers that the videos should start automatically and we have also tried to convert MP4 to AVI our and we have the same problem.


Is there a solution to this problem?
Thanks for your help!
Stéphanie

------------------------------------------------------------------------------------------

Bonjour,

Pour l'un de nos cours, nous avons utilisé des fichiers vidéo MP4 pour faire bouger les yeux et les lèvres de nos deux personnages. Sur ordinateurs, l'animation fonctionne très bien. Lorsqu'on visionne l'animation sur iPad, iPhone et Androïde, il y a un bouton Play qui apparaît sur les lèvres et les yeux.

Nous avons indiqué dans les paramètres que les vidéos doivent commencer automatiquement et nous avons aussi essayé de convertir nos MP4 en AVI et nous avons le même problème.

Est-ce qu'il y a une solution à ce problème?

Merci pour votre aide!

Stéphanie 

 

4 Replies
Ashley Terwilliger

Hi Stephanie,

Are you using the HTML5 output or the mobile player? Videos that are configured to launch in a new browser window may not automatically start playing in HTML5 output. This is a function of HTML5 browsers that can't be controlled. Some browsers will autoplay videos in this scenario, while others won't. If a video doesn't begin on its own, just tap it or click its play button.

HTML5 content can also not play multiple videos at the same time as detailed here. 

If you're using the mobile player or are still having difficulty and would like us to take a look can you share the .story file here with us. You can upload it or even just a snippet of it using the "add attachment" button at the bottom of the reply window.