Problems with Internet Explorer 11

I seem to be having a problem with a course not running correctly in IE 11. It works perfectly in Google Chrome and Firefox.

I have a page with 4 icons at the top. Clicking each icon displays info about an item, like a tab interaction. The navigation is locked down until each icon is clicked.

The problem is that all the icons cannot be clicked. The icons have a rollover state which is not apearing on rollover. The page does not respond to icons being clicked. To add to the problem it is not always the same icons that display this behaviour. If I refresh the page different icons become active/inactive

The behaviour has only just started, the course has been active for several months without problems.

IE11 is the standard browser in the company.

I have republished the course but to no avail.

Any help or ideas from the community would be welcome.

 

10 Replies
Alyssa Gomez

Hi there David,

Thanks for reaching out. I'd like to get a little more information on your set-up. Was this content built with Storyline 2? Can you tell me a bit more about where the content is located - either LMS or a web server? Also, are you viewing the content with HTML5? If so, Internet Explorer is not a supported browser for Storyline 2 content with HTML5.

You're welcome to share your file (or even just the affected slide with icons) here in this thread, and I'd be happy to test it on my end. You can use the Add Attachment button at the bottom of the reply window.

Dave Cox

Hi David,

As stated above, IE doesn't play well with HTML5 content. But, if that isn't the issue, I wonder if your browsers are running in compatibility mode?

Microsoft has a habit of doing their own thing, and not following the browser design recommendations. Awhile back, (IE8) to overcome some of the problems that jumping to a better design model they created a compatibility mode to allow code written for the older browser to continue to work. If your browsers are in this mode, this could be causing your issue. This mode can be enabled by a group policy, forcing it on to display corporate websites. 

You can go to tools > compatibility view to turn on or off this mode in IE, or you can add this line to your story.html file, in the head section, to force IE out of compatibility mode: 
<meta http-equiv="X-UA-Compatible" content="IE=EDGE" />

Ashley Terwilliger

Hi David,

You mentioned the behavior just starting to occur so I wouldn't suspect that something broke in the actual course file as that's been hosted on your site for some time now. Did you look into any changes to the LMS, server environment? What about changes to the browser and any new security restrictions, updates, etc.? I would definitely look into Dave's suggestions about compatibility mode too, as IE does have a way of making things more difficult. :)

If you're able to share the file privately you can always send it along to our Support Engineers here and they'll be happy to take a look. 

David C

Thanks for your replies. Dave, i have tried your suggestion but to no avail. Ashley, as far as i know there have been no changes to the server. Admittedly we have hosted it on a web server as our LMS will not be ready for a couple of months. Perhaps we should wait until the LMS is onboard then try it there.

Just seems strange. We have another course hosted the same way that is running perfectly.

Back to the head scratching.....

Dave Cox

Hi David,

Here are some steps that I take when I'm having problems with a web project:

Since you aren't currently hosting your file on an LMS, be sure that you publish for the web instead of LMS. This will produce the project without the code to interact with the LMS that might cause problems when the LMS isn't there to talk to.

In internet explorer, when your project first loads, press F12. This will open the debug window in IE, and allow you to inspect the code, and the DOM to determine what isn't working correctly. In particular, select the console tab and look to see what errors IE is reporting.

If you are running on a PC, it is very easy to install the local host web server. It is pretty much a service that you add from the control panel. Google for "windows local host server" for installation instructions for your version of the OS. Also, another good method is the USB web server. This is another way you can locally host the file where you can check it for problems. You don't have to put this on a USB drive. Any local folder will work. I find having a local server allows for easier troubleshooting and editing of code.

 

David C

Sorry for the late reply, I have been away.

Hi Dave thanks for the advice. The course is published for the web, looking at the console in IE11 showed there were no errors. I tried USB web server and all works correctly. I'm thinking it is some kind of network problem so i have got the IT guys looking at it.

Thanks everyone for their advice.

Aryasree Roy Chowdhury

Hello,

Hmm.... the same problem we have faced in our company with IE.

IE 11 version and tired below options and failed to run storyline

Tried and failed options:

1. Enable / Disable compatibility view for IE 

2. Tried to update IE and checked whether loading with IE Edge or 11 settings to run the storyline

3. Proxy settings and access certificates installed to run but still not working

Final solution we found by

1. Internet Explorer -> Tools -> Internet Options -> Privacy -> Uncheck "Turn on Pop-up Blocker".
2. Internet Explorer -> Tools -> Internet Options -> Advanced -> Under Browsing -> Check the box "Enable third-party browser extensions".
3. Internet Explorer -> Tools -> Internet Options -> Advanced -> Under Multimedia -> Check the boxes "Play animations is webpages" and "Play sounds in webpages".