Problems with showing and hiding layers

I am having DREADFUL problems getting this storyline to work.  The review copy is here.

You see the chevrons at the top on slides 2 - 4.  They are supposed to go black (ie live state) when you are on the layer and the state changes to normal when you click the back button below or one of the other chevrons.

I DO have all the state changes done and it was working.  But it has now stopped working properly and the chevrons remain black even though I HAVE GOT a state change to normal when you click the back button or one of the other chevrons.  The problems are mainly on the orange slide where there are 6 layers.  The second (green) slide (4 layers) and the final (blue) slide (2 layers) seem to be behaving themselves.  

I have put on some of the layers, state changes for ALL the chevrons to normal when you click the close buttons - but that does not help either.

Help!  What can I do about this?  Or is it a caching problem and the slides are actually working properly but not on my machine?

7 Replies
Ashley Terwilliger

Hi Tessa, 

I'd love to help figure out what's going wrong with these chevrons and their states. Are you able to share a copy of your .story file here with us?  If so, you can upload at this link using the Add Attachment button or you always have an option to share privately with our Support Engineers. Either way, we'll delete it when done testing. 

That way we can see all the states, layers and triggers to help make some edits to get this working again! If you choose to share with our Support Team, let me know and I can follow along in your case! 

Vincent Scoma

Hey Tessa,

Thank you for sharing your file! 

I went through the course and wanted to clarify a couple of things. I noticed that on slide 1.3, each chevron opens different layers. For example, with Chevron 4 it opens Layer 3

When I review the triggers for Layer 3, the back button is set to change the state of Chevron 3 and not Chevron 4

I spotted a few other inconsistencies with triggers such as when viewing Layer 3; if the user is to click on Chevron 2, this will reveal Layer 2. On your base layer though, Chevron 2 is set up to show Layer 4, not Layer 2, so I’m not 100% on how you intended those to work.
I made a Peek 360 video that shows what I see here: 

If you can clarify or take a look at my peek/findings and let me know what I missed, I am happy to point you in the right direction! 😄

Tessa Shepperson

Hi
Thank you so much for looking at this.  I am afraid the sound is too faint for
me to hear what you are saying in the video but it sound as if I have got my
chevrons muddled up.
Which surprises me as I did try to take care to do it correctly.  In fact I was
sure I HAD got them correct.
Basically the chevrons and the layers have the same numbers and when (say) layer
4 is being viewed,  chevron 4 should be black to indicate that it is the live
chevron / layer.
So then if you click to go back, then all the chevrons should go to normal.  If
you click the chevron to go to another layer - whether from the home slide or
from a layer, the chevron for the layer that is being shown should be black and
(if you are clicking from a layer) the chveron for the layer you are moving from
should go back to normal.  So you can see where you are at any one time.
I don't know if there is some sort of gremlin somewhere in the system as it was
all working correctly but then suddenly did not, and then it started getting
worse.  I tried to fix the problems but whatever I did it did not seem to work. 
Which made me wonder if there could be some sort of cache issue?
I did also copy the slides to see if I could change things in the copy (maybe do
it another way) but that was even worse and the colours for the layers were all
wrong and lots of other issues, so I just deleted it.
Tessa SheppersonLandlord Law Services Ltd
Web:www.landlordlawservices.co.uk | www.landlordlawblog.co.uktwitter:
@TessaShepperson
Free Weekly Bulletin: www.landlordlaw.co.uk/bulletinPrivacy:
www.landlordlawservices.co.uk/privacy
148 Unthank Road, Norwich, NR2 2RS | 01603 763096Landlord Law Services Ltd is a
company registered in England & Wales # 08153069

Tessa Shepperson

Strangely after going back to it after about a week I was able to resolve the
issues.  Which makes me think that there may be some sort of cache issue.
Thank you for your help.
Best wishes
Tessa SheppersonLandlord Law Services Ltd
Web:www.landlordlawservices.co.uk | www.landlordlawblog.co.uktwitter:
@TessaShepperson
Free Weekly Bulletin: www.landlordlaw.co.uk/bulletinPrivacy:
www.landlordlawservices.co.uk/privacy
148 Unthank Road, Norwich, NR2 2RS | 01603 763096Landlord Law Services Ltd is a
company registered in England & Wales # 08153069