Project is corrupt or invalid

Good morning. I have recently had a Storyline project I've been working on for 6 months become corrupt. Our IT team working on my computer for 2 hours last week to try and repair the file - to no avail. The 'corrupt or invalid' error message has appeared after displaying a different error message for a few days - 'this file is being used by another process and you do not have the proper security permission to access this resource. Make a copy of your file and open the new file' (see the attached pictures). This worked three times, and then it became corrupt. I do not have an up-to-date copy of this file that is not corrupt and am facing losing 6 months of work. I would appreciate any help anyone can offer. Many thanks.

12 Replies
Najam  Fazal

Sorry to hear that. Try:

  1. Checking your anti-virus if it's locking the file. When a file corrupts due to viruses, the AV scans and locks your file for access
  2. Checking your permissions which I'm sure you are good but just in case

If none work then try copying those files to another computer with SL installed and open it there.

Leslie McKerchie

Hi Miriam,

Corruption can be a tough one to nail down, but there may still be a working version of your project in your temp files. Here's how to check:

  1. Open this folder in Windows Explorer: %appdata%\Articulate\Storyline
  2. Scan the contents of this folder for a file that starts with the name of your project. If you find one, copy it to your desktop. If you find more than one, copy the latest version to your desktop.
  3. Change the file extension of the copy on your desktop from *.tmp to *.story.
  4. Double-click the file to open it in Storyline.

Common causes of file corruption are environmental (disk errors, power outages, improper shutdowns), viruses, failed Windows updates, and even file size (i.e., very large files have a higher risk of corrupting). Consider using the preventative measures described in this article to protect your project files.

Miriam Troy

Hi all. Thank you for the comments. Unfortunately I was not aware that working on shared drives and networks is fraught with danger prior to this happening. I have checked my temp folder and the only version available is a much older one - at least I won't have to start all over entirely. I have no idea why this file corrupted, or why I was seeing the error message stating I don't have the correct permissions - I have contacted Articulate Support and am hoping they will come back to me with an answer. Once again, thanks for your replies and suggestions.

Deepa Pai

I to am facing this problem today with a file that I worked on and published yesterday. I sent it to my client and he reported the problem. Now I see the problem on my machine as well. 

I have to deliver this file and have to redo almost half the project. I have already gone through all the possible suggestions for this issue from the last couple of years but none work! Phew! 

Unfortunately I cant share the SL file due to an NDA with the client. 

Posting this comment so that if any resolutions comes up, I'll know for future reference, 

Also, I have the AutoRecovery set to 10mins but no .tmp file got generated in the entire day yesterday. Wonder why!

Ren Gomez

Hi Deepa,

I'm so sorry you're coming across corruption issues and losing your work! We're here to help in any way we can, and I'm glad you reached out to our support engineers!

Your case has been escalated, so be on the lookout for a response to get to the root of the issue. I appreciate you sharing those additional details with Amlan as that will give us a head start in figuring this out!

Deepa Pai

Sorry for not updating this earlier. 

The issue was with a huge file in one of the slides [2.7Gb video].

Since I had to rebuild the project, I saved a version after every slide and made sure that I could open the SL file after it was saved. That's how I could pinpoint that exact slide because it crashed and the issue started recurring after I added that video. 

Is there a limit to the file size of media that we can add to SL? I am using SL3.