Prompt to resume feature is not working

Hi all,

I marked 'Prompt to resume' and published to LMS (in Storyline 3), but when the client tried to restart the course, it starts from the beginning and the message 'Would you like to resume?' doesn't appear. (I retested it in SCORM Cloud and it worked fine).

I've been given a solution to modify the file SCORM2004Functions.js:

find this block:

else if (strExitType == EXIT_TYPE_FINISH){

                WriteToDebug("Returning Logout");

                return SCORM2004_NORMAL_EXIT;

}

 and Change 'return SCORM2004_NORMAL_EXIT' to 'return SCORM2004_SUSPEND'

Is there any way to make that happen automatically in storyline and not manually?

 

 

 

 

26 Replies
Alyssa Gomez

Hello, Inbal!

Sorry to hear the resume feature isn't working correctly in your LMS. Smart idea to also test the output in SCORM Cloud, and it's good to hear that everything is running smoothly there.

What LMS are you using? Hopefully other folks who use the same LMS can chime in with their experience.

Diane Boewe

I am having a similar issue with Storyline 3.  Our courses are asking participants if they want to resume but it does not always take them to the actual place they left off.  It seems to go back several scenes and is thus not logging the participant's progress properly.  I too have used SCORM cloud and all is working there.  We are publishing as SCORM 1.2.  Does anyone have any suggestions?  

Alyssa Gomez

Hello, Diane!

It's possible you're exceeding suspend data limits in your LMS. In other words, your LMS has a limit to the amount of data it can hold. If you have a course that goes beyond the limit, the LMS won't remember anything that happened after the learner reached the limit, and it'll resume to the wrong slide.

Since you published with SCORM 1.2, try republishing your course with SCORM 2004 3rd Edition or 4th Edition, both of which support much longer suspend data. Let me know if you see a difference!

Patrick Small

Hello Alyssa -

I am a co-worker of Diane's and can provide a little more information.

We have tried publishing in both SCORM 2004 3rd Edition and 4th Edition and still have the same problem.  It doesn't always happen.  The resume feature will work throughout the course, but then suddenly, it chooses a single point to always resume to - even if more of the course is completed, and exited.  The "stuck" resume position never changes once it happens.  

We are using SimplyDigi (Vector Solutions) LMS.  Let me know if you need any other information, and thank you very much for your help!

Patrick

karen forkish

Hi Alyssa,

We are seeing the same problem publishing to HTML5 and SCORM 1.2. We use the Saba LMS.

The course tracks the number of slides viewed. Total number of slides is 130.

It's a compliance course that is locked down, so users are particularly frustrated to have to repeat part of the course that they've already seen. Particularly if they left the course because it froze on them.

It resumes correctly when viewing the slides up to slide 52.

After that, it always goes back to slide 52, no matter where you left off. And you can't jump ahead to the previously viewed slides after slide 52 because it is locked down.

The slides are mostly set to Reset to initial state, except for the checkup slides which are set to Resume saved state.

I'm not sure that we can publish to other versions of SCORM. Any other suggestions?

Thanks!

Karen

Julia Field

Hi

I am having a similar problem: Am using SL3 and published to 2004 3rd edition (as had same problem as everyone else with the resume data limit -I assume); with the prompt to resume selected; uploaded to Cloud SCORM; but it does not show the resume question at the start and as a result, any previous slides that are shown as having visited are shown. Please, please advise.

Ashley Terwilliger-Pollard

Hi Julia,

It sounds like you've enabled the prompt to resume, but no matter when you access it, you or your learners are never seeing that? 

With your permission, I'd like to take a look at your project file to investigate what's happening. You can share it publicly here, or send it to me privately by uploading it here. 

I’ll delete it when I’m done troubleshooting. 

fbs 419

Same deal here (Storyline 3 -- 3.6.18134.0), but Prompt to Resume or Always Resume never work.  It always goes to slide 1 on a restart.  I also tried setting the "When Revisiting" property for each individual slide to Resume Saved State.  It made no difference.  None of the choices made any difference. It always starts on slide 1.  We publish for LMS -- Tin Can API.  How can I get this to work?   Thanks

Alyssa Gomez

Hello fbs419 and Tiffany,

Thanks for letting us know what's going on! 

First, we'll want to rule out whether this issue is caused by your LMS or Storyline itself. To test that, we can upload the published output file to SCORM Cloud, an LMS testing tool. 

We'd be happy to help you with that testing. Simply share your original project file with our team here, and we'll take a care of the rest. 

Gerry Wasiluk

Hi, Richard!

Please see this thread that I started a few years back:  https://community.articulate.com/discussions/articulate-storyline/scorm-1-2-suspend-data-seems-wonky-to-my-pea-brain

Probably more than you ever wanted to know but some good suggestions in the thread on what you can do to try and reduce the amount of resume data when course is to be published to SCORM 1.2.

Alyssa Gomez

Hi Colin!

I took a peek into Tiffany's case, and I see that the resume issue she saw was related to the SCORM standard. Republishing her course using SCORM 2004 3rd edition fixed this behavior. 

It sounds like the issue you're seeing is a bit different, seeing as you're already using that SCORM standard. Would you mind sending us a copy of your file so we can take a look?

If that works for you, you can upload your file privately to our support team here. We'll delete it when we're done troubleshooting.

Victor Madison

I have upgraded to Storyline 3 from Storyline 2.  In the past, I have published courses (CD version) and had no issues with the "resume course" prompt.  Now, in storyline 3, I don't even get the prompt - the course just restarts at the beginning.  I have the resume feature set to "prompt on resume" in the player.  Is there a problem with this feature in storyline 3?

Vic

Alyssa Gomez

Hi, Victor!

Courses published to CD should resume where you left off, as long as you are accessing the course from the same computer.

Our support engineers can lend a hand with testing the output, if you'd like. If that works for you, you can upload your file privately to our support team here. We'll give it a test and let you know what we find!

Ren Gomez

Hi Venkata,

Sorry to hear you're coming across this issue as well! Firstly, you may want to try testing the published output file to SCORM Cloud, an LMS testing tool to see if it's Storyline or LMS related.

If you find that everything is ok in SCORM Cloud, it may be that you're exceeding suspend data limits as well.

We'd be happy to help you with that testing. Share your original project file with our team here, and we'll take a more in-depth look into your file.

Rachel Crabtree

We are also using SCORM 2004, 4th edition via Storyline 360 with IE (on both Win 7 and 10).  It is an inconsistent problem.  Though the suspected problem is that the Edge doctype isn't available on some IE browsers.  At least that is the floating theory in our organization anyway.  Also I should add the "resume state" option is selected in the player, most of the slides are set to "reset", and the course passed fine on SCORM Cloud.