Prompt to Resume or Always Resume is not working with xAPI

We recently move from using SCORM to xAPI (Tin Can). I created a an interactive video. Everything is working fine when uploaded to our LMS. But the only issue is, the Prompt to Resume or Always Resume is not working. There is no prompt appearing or if the always resume settings is on, its not resuming at all. We have to play the whole interactive video again.

We are using Storyline 360, Docebo for LMS, and the latest Chrome browser. I tried testing it on SCORM cloud and encountered the same issue.

Can you please advice?

Thank you.

5 Replies
Ren Gomez

Hi Junard,

Thanks for reaching out! To confirm, were you able to resume in the middle of the video when you published this course for SCORM?

This discussion here dives into that topic and describes the expected behavior that a video only partially viewed will reset when revisited.

I hope that helps clarify your question!

Junard Basilio

Hi Ren,

I tried publishing the course in SCORM and encountered the same issue. 

Ashley mentioned in the link you provided that "If you're using the slide property setting for *When Revisiting* to `Resume saved state`, the correct behavior would be:
• If the video was fully played, it would not restart when returning to a slide.
• If it was partially played, the video would resume from where it had stopped when the user left the slide."

But Leslie also said that "1. Exiting a course on a slide with a video playing and resuming on the same slide, will reset the video. This is the expected behavior."

To give you an idea about the structure of what I am doing, I have one slide with one video on it. I created a knowledge check in that slide using layers, The knowledge check appears randomly within the video.  The video duration ranges from 3-8 minutes. If my understanding is correct, according to Leslie, if a user exited the course with a video playing and resume it on the same slide (since I only have 1), it will reset the video. But according to Ashley, if use the slide property settings correctly, the video would resume from where it had stopped when the user exited the course.

I am missing something here? Thank you.

Lauren Connelly

Hello Junard!

Thank you for providing these details! It sounds like the resume behavior isn't working as expected. When the course resumes, it should return to the slide and reset the video.

The next step in troubleshooting is to take a look at your project. Are you comfortable uploading your project in a support case? This will help us test the file and determine the fix.

Junard Basilio

Hi Lauren,

I think you answered my inquiry: When the course resumes, it should return to the slide and reset the video. --- so the video resetting when resuming a course is an expected behavior? Because I assumed that when you resume a course, the video will also resume to the timestamp where the user closed the course.

I apologies as I'm still relatively new to the platform.

Leslie McKerchie

You got it, Junard!

  • While you are in the course and the slide property is set to 'Resume saved state,' then a  partially played video would resume from where it had stopped when the user left the slide.
  • If you exit the course entirely, Storyline will return to the slide you left off and resume from the beginning of that slide (which would reset the video).