Publish crash

Hi there,

I have a course with 3 scenes, totaling 68 slides for now. I'm going to add the 4th scene later. Currently it's 17.5MB. When I publish it crashes when it gets to the "optimizing images" part of the progress bar. It does this without fail. I have managed to publish scene 1 and 2 previously - after trying half a dozen times. Scene 3 as well after trying half a dozen times. It always fails but then doing some fixes seems to sort itself out. Like....  I put the file and publish the output to desktop (this seemed to be an issue when the path to the C:\Users\xxx\Documents\My Articulate Projects\ was too long and publishing to the Desktop with a short name seemed to fix it). Someone said make a change and publish straight after saving - done that. Today I've added a re-install SL2 to my list, I ran the SL cleaner file (using this support page), All my fixes that I have tried which worked previously are not working now when publishing all my scenes together... I have tried 8 times today an I'm about to scream :) I really need this published because of deadlines. I'm going to send a ticket to support as well. Wondering if anyone has any ideas?

 

PS I'm using SL2 update 9

16 Replies
Crystal Horn

Hi there, Jordan.  I'm sorry you're getting hung up!  I'll need some information so I can help you out:

  • Are you saving and publishing to your local C: drive?
  • Is the file path to where you're publishing super long?  (technical term ☺️)
  • Can you successfully preview the entire project?  If not, are there any scenes that won't preview?

Thanks for the information!

Jordan Orzolek

I am having the same issue and I have followed the steps to fix aberrant behavior in SL2. I'm attaching my error log. This happens with any of the files I try to publish not just one. One of my coworkers downloaded SL2 and we tried to publish from his computer but we wound up getting the same error.

Guido Roessling

I have a similar problem here. Setting: using a Storyline 2 file, opened in Storyline 360, try to publish to Articulate 360 ("publish a new version of an existing item") fails reliably.

One hypothesis that I have is that a story cannot be opened if somebody is currently reviewing it (in preview/feedback)...?

Here is the error message (part of the info displayed when clicking on "information"):

Access to the path 'C:\Users\groes\AppData\Local\Temp\Articulate\Storyline\5a26RKVliDU\360\story_content\Slide5o7JLTfHWBZ.swf' is denied.

StackTrace:

at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize)
at System.IO.FileSystemWrapper.FileCreate(String filePath)
at Articulate.Design.SlideBackgroundImagePublisher.Publish(ExportBackgroundEventArgs e, CreateBitmapDelegate createBitmap, String uniqueKey, IPlayerCache playerCache, String tempDirectoryPath, Size size, ImageConverter imageConverter, IPlayerPublishSettings publishSettings)

Ashley Terwilliger

Hi Guido,

You should be able to publish while someone else is viewing the course, but it will refresh the page for them so it could definitely be confusing.

Have you tried publishing it as a new item altogether and that one works normally? What about republishing it as a new version of an existing item that you haven't shared with anyone yet? 

Also, you mentioned that the files are upgraded from Storyline 2 - have you only see this with files upgraded from SL2, or that's all you've tried so far?

Guido Roessling

Hi Ashley,

thanks for the fast reply! I have only tried uploading content imported from SL2 so far (my project colleague "only" has a SL2 license, so there is no real "SL360" content so far).

Also, on looking at the error message above, this seems to indicate some path/missing file problem, not really an upload problem per se...?

Edit: I assume that it may have something to do with the local VM (I'm on a Mac) it's running on. I can easily publish the same 360 file (from the same GitHub) to Articulate 360 on my VM at home (another Mac), so it's probably a "local" thing...

Alejandro González

Hi there,

I just tried to change the path I'm publishing to a different folder and it apparently worked :D Previous folder was local and its length was ok.

The file that got stuck was some .mp3 file. Could this be related to my habit of deleting old output files before publishing the course again? Nothing else comes up as a possible explanation.

Regards,

Alex