Published video plays for ~20 seconds then stops but previews to the end

Like the title suggests, I'm having an issue with a video. In preview mode, it previews perfectly from start to finish. I had a previously published this .story for web (including the video) and it went great! I made a minor change to the .story and republished it (the change did not even take place on the slide with the video) and now the published version plays the story up through about 20 seconds of the video and then stops completely.

 

I've seen other threads talk about security settings but this doesn't feel like the case because 1) a previous version of this .story worked well and 2) the video plays for a while but then just stops at the exact same point every time I try to preview it or re-upload the published files.

 

Ideas?

8 Replies
Macy Frost

Brian,

 

THANK YOU for replying!

 

Checking the story_content folder is a great idea I didn't think of. No, it does not play through to the end. It stops at the exact same point as it did while playing the published story in it's entireity. (~ 20 seconds in.)

 

Does this tell you/me/us/anybody anything regarding how to fix?

Christie Pollick

Hi, Gloria -- Thanks for reaching out and sorry to hear of your troubles! For good measure, I wanted to pass along this article for when Videos Don't Play in Published Content. And I also wanted to ask, are uploading the published content to an LMS or to the web? I was wondering if you are finding the same behavior on the SCORM Cloud (for LMS) or via tempshare.articulate.com (for Web). And may I ask if you have tried importing the file into a totally new file to see if you find improvement?

Macy Frost

Hi Christie,

I believe everything in the link you provided is set up just fine, as the video is visible and plays for some time but then just stops.

I'm uploading published content for the web. Just for the heck of it, I've also tried publishing for LMS and uploading that (what can I say, I'm desperate) with the same results. I haven't tried actually uploading it to our LMS yet because our HRIS analyst who uploads to our LMS is gone this week.

The last few hours I've been trying to import the presentation into a new file. I did it once with a blank/template-less file and it actually worked. (whoa!) BUT because the player was way different than it needed to be and I assumed that would be an easy fix, I closed the file and re-imported it into a file where I applied the template with the correct player that I wanted. Then it did the normal stop-after-20-seconds thing it's been doing. I tried about 20 times after that and at first I was having the same outcome but then it stopped publishing entirely and I'd get an error during the publication step. I even got so desperate as to try to re-import the video file itself into a completely empty story, so the video would be the only content in a brand new template-less story, and that error-ed out while publishing.

 

I just don't understand! I have a ticket into the articulate support team; however, I can't upload my file to them and I get error messages when I try. (I also can't upload the .story file to a file sharing service and just give them the link because I work for a government contractor so all file sharing is blocked from work computers.

 

I swear I'm batting a thousand here...

 

Macy Frost

Update: I was able to send the Articulate support team my file by using a different browser so it's at least in very capable hands! But the problem still persists as of now so if anybody else has experienced this, please let me know what you may have found OR any ideas you think I should try!

Christie Pollick

So sorry to hear you are having such a tough time, Gloria, and I am glad to hear that you were now able to share your file! I see that our Support Engineer, Eloisa, is working with you in your case #00846164, so I will continue to follow along with the progress being made and hopefully we can get you straightened out as quickly as possible! 

Ashley Terwilliger

Hi Phoebe,

This discussion is a bit older - so let's start fresh! 

  • What version of Storyline are you using? 
  • Where are you hosting/testing your published output? 
  • Is this happening with all videos or Storyline files, or one particular file?
  • What browser(s) are you viewing your published content in?

Any sample files, screenshots, or screen recording you can share will also help us take a look!