Publishing doesn't complete

I've used Storyline before and I've never had any problems with publishing, so I don't know why any form of publishing (including running previews) either don't complete, or just pause entirely.  I have tried publishing into web, LMS, CD, Word.. none complete the publish process.

When I publish the final product, the process begins, but then the "Publish" menu box disappears.  There is no prompt of any publishing being completed.  When I access the destination output folder, the index_lms.html, player.html and XML files aren't there.  The story_content has published, the LMS folder is empty, and for some reason there is also a Temp folder which is also empty.

It fails even when I want to preview a specfic scene, or a particular slide.  Either it will preview something else, or nothing at all.

I have a full version of Storyline, but I have noticed that on load up, Storyline says I am using an older version now.  It says to download and install the latest build, but when I click on the given link, it takes me to a 404 page.  Clicking on the publish option fot HTML5 is also disabled and states "Sorry, this feature is unavailable in this Beta release."

I've tried closing all programs that are open before publishing, I've tried duplicating the presentation, I feel like I've tried everything but nothing is working.

Please help me!!

41 Replies
Bruce Roberts

I'm also having problems. 

Publishing to SCORM1.2 with "Include HTML5 output" selected fails every time when the project is large (Over 600Mb), 

Sometimes with a message to report the error, sometimes SL2 simply shuts down.  
Publishing Works fine when "Include HTML5 output" is not selected - this is a big problem for me.  I have applied all suggested fixes - re-installed SL2 with latest version, removed & re-installed Flash, removed & re-installed dot net 4.  Also used the Articulate registry cleaner.
My PC is an i7-3770 3.4Ghz processor with 64bit Windows 7 and 8Gb RAM.

 

 

Crystal Horn

Hey Bruce.  I don't see it in our private queue, and I don't see a current case with our support team.  Something might be failing between your computer/browser and the upload form.

Can you try to go through the normal support case process, and if that upload doesn't work for you either, go ahead and continue to submit the case.  Our support team might give you some other options for sharing your file.

Bruce Roberts

Hi Crystal,

I tried the normal support case route twice this week and I think the file is too large for your system.
I'm sending you a link to the file using "We Transfer"
You should receive a notification to this email address in about 10 minutes.

Kind regards

Bruce

Bruce Roberts
Assima Customer Relationship Management

Find out more about:
Automated Business Improvements from Assima<https://www.youtube.com/watch?feature=player

Bruce Roberts

Hi Leslie,

Thanks for this.  It's good to know that pressing reply in a support email, results in the conversation appearing here.  I'll avoid doing that in future. 

One item that may interest other authors, if they have this problem is to reduce the quality of the output (as a test) using "Custom optimisation"  Setting the quality REALLY low, such as Video = 4; Audio = 56kbps & Images = 30% .  This successfully produced a SCORM1.2 package just a shade under 1.0Gb.  Anything over 1Gb causes SL2 to tilt.  Not sure why this is, but it's hopefully now with the support team who will investigate.

Bruce Roberts

I think I have discovered what the problem is as I've had success in publishing this content in excess of 1GB.

 The problem appears to be caused by how Storyline deals with "orphan" slides...

 

How this appears:

When a lesson was reviewed, our client identified slides that they did not want in the final version of the lesson.

We could not delete these slides immediately as, with Storyline, should we have done this, all the subsequent slides get renumbered and we would not be able to identify change requests needed for subsequent slides.

This is an issue for anyone using the Storyline MS Word Export or the "Review My eLearning" tool.

 

How it is caused:

What we do, if we want for instance to delete Slide 5, is to target the "Next" button in Slide 4 at Slide 6.  We also target the "Back" button in Slide 6 at Slide 4.  This results in unattached slides appearing at the top of the scene, parallel to the main core of "good" slides.  This seems to be OK when you just have two parallel columns of slides, however where there are more than two columns created by Storyline.  (See Deletions.jpg attached)  This appears to prevent the generation of HTML5 content causing Storyline to throw an error, or simply crash and close.

 

How to fix it:

Simply delete all your orphan slides (IF you don't need them) OR setting the navigation of the orphan slides to point sequentially to the next orphan slide and hiding (off screen) a button on the last "good" slide of your lesson, targeted  at the first orphan slide, brings all the orphan slides in line with the "good" slides & keeps the numbering.  This allows full HTML5 publishing and prevents a learner from seeing the orphan slides until they are due to be deleted in the final release of the lesson.  The "deleted"/orphan slides can be marked clearly for deletion so that the client can see this in your subsequent Word Output review version.  Slides can also be "Seen" to have been "deleted" when using the "Review My eLearning" tool.

The subsequent project will still need to be imported into a new blank storyline project, as unless the orphan slides are re-organised, importing the slides into a lesson the same size will seemingly, consistently fail to publish with HTML5 output selected.

Warning:

You may well lose Variables as a part of the import process.  I had 40 Variables with a "Use Count" of "0" as they had not yet been defined.  All of these disappeared.  This is a known issue - see: https://community.articulate.com/discussions/articulate-storyline/variables-lost-when-importing-one-storyline-2-project-into-another-one

I hope this helps anyone that reads this far :-)

 

Leslie McKerchie

Thanks for the update Vijay. Have you attempted to upload to SCORM Cloud? Sounds like at this point you are successfully publishing the content, but now we need to know if the issue is within that package or your LMS. If you are able to replicate, please feel free to share your project so that I can take a look.

vijay s

Hi *Leslie McKerchie *

*I was able to upload to scrom cloud without any issues.*
*even i tried unzipping the file in server and connected imsmanifest.xml
to the course it works fine there. (through FTP uploaded scrom package)*
*but when i tried uplaading the zip file it shows error .since i want the
user to download the course i cant use the second method (connecting the
imsmanifest)*

Leslie McKerchie

Hello Vijay! Thanks for letting me know that the content is working as expected in SCORM Cloud. Based on that finding, I would advise following up with your LMS team.

Typically the error with the manifest not being found is due to improper zipping as you can see here. If you can successfully upload the same content to SCORM Cloud, that doesn't seem to be the case. We have some documentation here on common LMS issues, but I do believe following up with your team will be best.