Publishing process is not completing successfully with large file.

Hello,

I'm currently working on a VERY big project file and discovered today that when I attempt to publish to web or for LMS the publish process isn't completing successfully. I noticed that something wasn't quite right when I didn't get the successful publish screen appear to give me options to view files, zip etc. Instead the initial publishing window came back. Having looked through my published articulate projects directory I found the project in what looks like a mostly published state however on attempting to open story.html I am getting an error message stating that data.swf could not be found. Sure enough it's not where it should be in the story_content folder.

Having looked through the forums I found one or two other contributors posting about a similar issue and that file size may have been a factor. I was wondering if anyone has experienced this issue and found a resolution for it? As this is a very time sensitive project, this error has certainly thrown a spanner in the works.

As a side note: I AM able to successfully publish for CD. However as this course will be hosted on a Tin Can based LMS, this is of little help to me. I was wondering if the data.swf file that is created in the publish for CD process is the same as the version of data.swf that is created when you publish for web/LMS? If they are, then could I use the data.swf file that is created during my publish for CD process in the files published for LMS?

Hopefully this all makes sense. Any help or advice that the community might be able to offer would be greatly appreciated!

Thank you for reading,
Tom 

7 Replies
Thomas Stembridge

Hi Ashley, thank you for the warm welcome!

Memory has been an issue in the past with my machine. It's a powerful set up but I have had troubles saving the file after a day of solid usage before. I may look into shutting down some non-essential processes to see if this may help.

The course clocks in at around 860 MB featuring around 1030 or so slides over 67 scenes so it has certainly made SL quite sluggish. Thankfully, when I found I was able to publish for CD, I tested out story.html and story_html5.html and both still ran well.

Thank you again for your help, Ashley. I enjoy using Storyline very much and I would be interested in hearing of other development experiences with large courses/projects. :)

Tom

Ashley Terwilliger-Pollard

Thanks Thomas for the update, and that's definitely a large file, but I'm happy to hear you were able to publish to CD and have it work for you. 

It looks like in the previous thread, Dennis has had a lot of experience with large courses - you may want to PM him to get some additional thoughts on his development process with large files. 

John McLeod

I'm having the exact same issue as Thomas, the publishing doesn't complete and I'm left with a publish folder including a folder called story_content, a Temp folder (containing font.xml and tex.swf), a story.swf file and a meta.xml file. I get the same error when trying to play the swf file as thomas mentioned.

The difference is that I'm running this on Parallels (Windows 7 Professional virtual machine). I've bumped up the amount of RAM available to 8 Gs. I tried smaller files to see if it was the system and they publish correctly. I'll try bumping up the RAM it uses further ( I have up to 16 available).

The file size is 148 Mb.

I'd appreciate any insight others have to this.

warmly,

John

Ashley Terwilliger-Pollard

Hi John,

In addition to the ideas shared above for Thomas, I also wanted to remind you of some best practices when working in Parallels and to ensure you're publishing to the local drive on the Windows side, and adhering to the file path limit detailed here.

If you're able to increase the overall amount of RAM, that would be a good first step. I'd also shut down any other programs or processes that are open when you try to publish.