Question States Displaying Incorrectly/Automatically Resizing

I'm seeing an issue on question slides that was a known bug when SL was in beta, only it's not in beta now and yet the problem is still happening. When I create a (multiple choice) quiz slide using the built-in slide master question template and then put in the answer options, the states for the answer options don't correctly display. I included some examples below.

The normal state looks fine, but the hover and down states automatically resize so they don't fit in the bounds of the text box. This is not only really annoying, but also a big time suck, since the only way to fix it is to make changes by hand to each individual state that's incorrectly displaying. My whole course is essentially one big quiz. I don't have time to fix everything by hand. How can I get the states to display correctly (as they should) and, more importantly, why does this bug still exist?!

Normal state

Hover/Down states

Normal state

Hover/Down states

34 Replies
Christine Hendrickson

Hi Laura,

Thanks for providing all of the screenshots, that helps a lot! Have you installed this update for Storyline, yet? If not, please install the update and see if you still experience the same problem. If you continue to experience the same problem after installing the update, we'll need to investigate this a little further.

Thanks very much,

Christine

Randall Sauchuck

I am running into the same issue (I am using Storyline 2 and have installed all updates)

It seems that if I re-size a multiple choice item's text box only the normal and selected states show the change. The Hover, Down, and Disabled states remain the original default size. I have to go through and manually change 3 STATES ON EVERY TEXT ITEM ! This is a huge waste of time.

RM  Administrator

Hi, we're having the same problem on multiple choice questions but it's always the 1st and third options in a 4 option test when the answer goes over more than one line and the hover state for us changes height not width, only way to change it is manually every time.

However, we've noticed that it only does this if we are pasting the text in the Form view of the question slide - if you paste it straight into the text box on the slide view itself it does not seem to do this, so not sure if this will help you.

Any ideas on why this happens will be greatly appreciated as it's really annoying.

An example is attached showing the difference between entering question content in the two views.

Randall Sauchuck

I have noticed something else about this bug. It usually happens to any answers marked as correct (selected) when the item is edited. If you apply the transformations to the items before selecting them as correct then everything seems to work. Hope this info helps your dev team track down the bug because its a PITA to deal with.

 

Leslie McKerchie

Hi RM!

Are you able to re-create this issue, if you do not use your custom layout, in a new, blank file? I am unable to re-create the issue you are reporting.

Randall - I did not hear back from you on your ability to consistently repeat your issue.

If you could work directly with our support team here and we can get this report going to QA.

RM  Administrator

Hi Leslie,

We have been able to recreate it starting from scratch - it's easiest to see it happen if you change font and background colours so that the hover and selected  states are different to the normal state.

We're attaching a template we made and then a file made from it, where text was pasted into the options fields.

As you can see the selected, down and disabled states have all displayed this issue this time.

Raised it as ticket 00690932.

Ashley Terwilliger

Hi Katherine,

I'm sorry that you've run into this issue, but it is still with our QA team for additional review and investigation. I don't have any updates to share at this time, but as Leslie mentioned above it's in the hands of our QA team for additional investigation and we've included the thread for reference as well and so that we can update users once there is additional information.

Bastien Médard

Hello,

For your information, we have the exact same issue when importing translation into a quiz. At least one or two options box size in states get changed, and we need to fix everything manually.

I hope this will be solved as it is really frustrating and time consuming for large modules (we are managing more than 50 modules and this happens in everyone of them).

Thank you,

Bastien

Leslie McKerchie

Hi Dan!

I do not have an update to provide on this issue and it looks to still be in the hands of our QA Team.

This thread has already been added for both user awareness and update when applicable, but I'll add a comment to be sure they are aware that users are still being impacted.

Would you be able to share your .story file?

Pink Lady

I was running into the same frustrating issue for a while but another developer informed me about importing the Quiz questions instead, and that seems to have done the trick!  I haven't had a problem with the questions since.

The import template I used was this one:  https://community.articulate.com/series/articulate-storyline-2/articles/importing-questions-into-articulate-storyline-2  (Right-click on the download link and "Save as target".  Change the extension to ".xls")

Here is another one, but I haven't tried it:  https://community.articulate.com/download/question-import-template-for-quizmaker-13-storyline-2

Hope this helps!