Quiz glitches in multiple choice buttons and inaccurate results slide output

I have multiple scenes with a 5 question quiz at the end of each scene. The user is able to review their quiz result and review at the end of each scene. At the end of the entire presentation there is a final quiz results slide which compiles the results of all the scenes quizzes together. I'm running into several very odd glitches when the user takes the quiz.

The first glitch is that the multiple choice question buttons occasionally will not be active for the user to click. This glitch has happened with only a few users and there is no obvious pattern as to why this would occur on one persons computer but not on another.

The other glitch is that we are getting inaccurate quiz results when the user reviews at the end of each scene. For example, if I answer 4 of 5 correct the output on the results slide says 0% correct at the end of that scene. However, when the final results are compiled from all of the quizzes at the end of the presentation it is correctly reporting the results and giving me credit for the 4 correct answers. Why would the results slide not be giving me correct results?

These don't seem to be browser dependent errors because I've tested in Firefox, Safari, IE and Chrome and the error happens in all of them. Does anyone have any ideas what could be causing these glitches? Thanks for any feedback!

 

13 Replies
Ashley Terwilliger

Hi Michael,

It sounds like we may need to take a look at this .story file to see what's happening and try to replicate the behavior. Can you share a copy here with us? 

In regards to the review, do you mean when they just view that results slide - or are they clicking on a "review" button to navigate back through the questions they answered? If the latter, I'd check that the slide's revisiting properties are set to "resume saved state" so that on the review they're not inadvertently being adjusted and reporting as incorrect. 

Michael Mueller

Hi Ashley,

I've attached my .story file...it's a rather large file.

In regards to the review I'm referencing is when the user is done with the 5 questions and they arrive at the results slide the % correct number is not accurate to the results they actually got. When you go back thru and review the quiz it shows lets say 4 out of 5 correct, however the results slide shows 0 correct. I'm using "resume saved state" on the quiz questions. I've tried it several different ways and it doesn't seem to have an effect on the results slide output.

What is odd is that I built the individual scenes separately and then imported them into this document. When I take the quiz from the individual scene file I don't get any errors, the results at the end of the quiz display accurately. However, when I import the 4 scenes into the same document and take the quizzes from there I get these errors with the results. The results slide at the very end of the document is adding up the total from the 4 scenes and displaying that number correctly despite the fact that the results at the end of each individual scene is not correct.

Thanks for any input you can give.

Peter Moore

"The first glitch is that the multiple choice question buttons occasionally will not be active for the user to click"

I am seeing this also.  Custom quiz buttons are not active/available for clicking. In my case they work fine in preview but they fail when published.  There is no state change on rollover and no 'hand' pointer cursor on rollover.  Tried both IE 10 and Firefox browsers.  Also tried publish to LMS and simple publish to Web only.  Same result.  Looks like the output has partially crashed.  I say partially because one other button on the screen (jumps out to another slide) does still function.

Ashley Terwilliger

Hi Michael,

Thanks for sharing the file. I took a look and there is some odd behavior on your results slide as they're all using the same Results.ScorePercent variables - and I can see there is only a total of two different sets of Results variables - even though you have 6 different results slides. This may have happened as a part of the import - but you may need to recreate those results slide to have the proper variables be generated for viewing and reference the score as the user would need to see it from the Results slide in each scene. 

When importing your files, you'll also want to confirm that you're working locally as described here as that is one of the known causes of odd behavior in project files. 

I didn't see the issue with  not being able to click the buttons - you mentioned it only happened for a few users? Were you able to determine any particular set up that was causing this behavior? 

 

Peter, you mentioned you're also seeing this behavior on custom buttons? Does it occur every time for you or as Michael mentioned only particular users?

Michael Mueller

Thanks Ashley, you are correct in that if I replace the results slides it changes the "Results.ScorePercent" variables to include a number that differentiates it from the other results slides. I'm working locally on my hard drive so it must be just an odd error coming from importing the scenes that those variables didn't update.

I've not been able to replicate the buttons error on my computer, so I'm hoping that error for some users was related to a similar import issue like the results slide which is now resolved by replacing those slides.

Thanks for your help.

Peter Moore

Hi Ashley.  I'm still in development with this module and this problem occurs every time.  The module is unusable as a result.  In my case we have a 'Button Set' as part of a 'Pick One' interaction.

I havn't been able to get back to it for a few days but will take another look soon.

Do you know if SL 2 update 4 has any aversion to having buttons copy/pasted between slides when they are part of a button set and part of a pick one interaction?

Ashley Terwilliger

Hi Peter,

I tried this in Update 4 of SL2, and everything works well when previewing, I published for web and tested it locally - and then uploaded to Tempshare, and each time I can click a button and then hit submit. You mentioned copying and pasting, and typically I'd recommend duplicating the slide as copy and paste sometimes has odd behavior. Also you mentioned you published and tested the web and LMS - but did you upload into those environments? Testing locally can sometimes exhibit odd behavior as described here. 

Peter Moore

Hi Ashley - I think we have a deeper problem. Something related to the handling of results and the results slide.  If I edit the results slide and untick any of the questions so they are not included in the results...then I don't get the problem  i.e. I am able to select one of the buttons in the button set on the slide that I have excluded on the results slide.  Of course this is no solution as I need those results included, but its a discovery which looks like it should be a useful clue although I haven't been able to discover how as yet.

I have tried the following:

1. Duplicating the results slide and deleting the original - just to see if there was some corruption in there.  No change

2. Duplicating the first question slide where the problem manifests (Question 2) and deleting the original. No change

3. Deleting the existing buttons forming the button set and re-creating these. No change

4. Removing and re-creating the freeform setting on the slide and re-selecting the button targets for the pick-one interaction.  No change, but there is a bug here where SL will create (by itself) a new 'selected' state for a button when you remove and re-create the freeform slide (even though there is already a selected state graphic there that I created) and place a light coloured shadow behind it

I have also tried opening previously created Storyline files relating to other courses but carrying the same structure and triggers as the one I am working on now.  All of these now exhibit the same type of failure (unable to select a button in a pick one set) that I am seeing with this current file.  They had all previously successfully published and been put into production on the LMS.

I am somewhat in a pickle with this I have to say...thinking about what I could possibly try next.

Maybe there is something about SL2 Update 4 that handles results or manages button states and their triggers in a different way now? Any thoughts or advice much appreciated :-) 

Ashley Terwilliger

Hi Peter,

Were you able to confirm that you were working locally? Working off a network drive or USB drive could cause corruption issues, and duplicating a slide will not likely resolve the issue as it's within the file itself. You may want to look at importing into a new .story file and confirm that is on your local drive. 

I tested myself with Update 4 of SL2 and didn't see any odd behavior - so I'd also like to take a look at one of your .story files. 

Peter Moore

Hi Ashley.  I am working locally. C or D drive depending on which machine I am using.  I do transport .story files on a USB drive between my work locations but always copy these onto a local drive to work on them.

I did also import all the content of one of the SL files that is not performing...into a newly created SL file.  Forgot to mention that in the last list. How do I send you a .story file privately. Pete