Quiz Graded Wrong on Results Slide

Hi.  I have a module with 60 or so quiz questions.  I have a results slide configured to publish to LMS, with "Track using quiz result" set, and "Output Options" set to "LMS: SCORM 1.2" and "Report Status to LMS as" set to "Passed/Failed." The individual questions are all configured as "Feedback" set to "None," "Shuffle" set to "None," "Score" set to "By Question" and "Attempts" set to "1."

This quiz module is the final module of a 9-module course.  I also have quiz questions in the previous modules.  But I don't have "results" slides in those modules.

My problem is that when I test the quiz module, I get incorrect grading results.  Each time I test it, I enter all the answers correctly.  But when I submit for grading, the response is that I failed.  When I review my answers, I find all my answers are correct.  But at a random point within the quiz (usually towards the second half), the answers start being graded as wrong, even through you can see in the reviewed slides that the entered answers match the flagged correct answers.  After the incorrect grading begins, all the question slides that follow until the end of the quiz are graded as incorrect (yet they are correct).  I am testing the module through an LMS (LearnUpon).

When I exit the course and then "resume where I left off" and then resubmit the "results" slide  (without retaking the quiz), it grades the same quiz answers as 100% correct (I'm not sure if that happens every time, but it has happened).

I've tested this in Firefox, IE and Safari and the behavior is the same in each.

Can you help?

Thank you.

Rich

11 Replies
Justin Grenier

Good Afternoon, Richard.

If you're experiencing issues with LMS content, please refer to this article, which outlines common issues pertaining to viewing and tracking content in an LMS.

Also, be sure to package your published content properly for your LMS.

If the issue persists, open a support case with your LMS provider, since they're your primary source of support for LMS tracking and reporting issues.

Richard  Crouse

Hi Justin.  I went through the article you referenced and it appears that the issue was having Storyline set to launch the player in a new browser window.  The LMS from LearnUpon also launches in a new window.  Apparently the competing player instances somehow corrupted the reported SCORM data.  I described the issue and fix to the folks at LearnUpon so they'd have that in their tech support records in case other users experience the same issue.

Thank you.

Rich

Natasha Bomba

Hi. We are having a similar issue with SumTotal. I have two quizzes in the course. On their own, the final score is fine. The results slide, however, is sending the wrong result to the LMS. If we fail a quiz and retry it, it sends both instances to the LMS (not sure if this is normal or not--we've just started with Storyline). But what's definitely not normal is that the score is wrong. It's calculating 100% which is impossible given there are some errors. Learner must get 85% to pass total score. Because there seemed to be issues with adding the two quizzes, I set up the last slide to just calculate the results from all the pertinent questions. It seems like the reset results triggers may not be working? (but they are there). Here are some screenshots...I can't share the course because of confidentiality issues.

Natasha Bomba

Also, I've noticed our SL file has been glitchy with the results slides (on the assessments and the final results). The checkboxes on the slides that should be scored sometimes randomly drop off. Not all, but one here or there on in the case of our final score, one whole assessment will drop off. Has happened to two of us so it's definately not user error.

Leslie McKerchie

Hi Natasha - Would you be able to test your output in SCORM Cloud? This would help determine if the issue lies within the course or within the LMS.

If you are having glitchy issues with your course, you may want to consider importing the slides into a new file to see if that eliminates the issue you are seeing.

Natasha Bomba

Hi Lesley, can you clarify something for me...If I have two assessments, each with a graded score at the end then a final results slide, will each of those slides send results to the LMS? I only want the final slide to send the results (which would be a total of both). Also, if they have to redo one of the tests, where is the trigger to reset the results? I can't see it.

Leslie McKerchie

Hi Natasha - You can certainly have multiple results slides, but you will only be able to send one to the LMS. So, yes, you could have a 'result of results' slide that you would then send to the LMS. As far as being able to retry a quiz, that is set within the result slide options and a trigger to reset the results will be added automatically :)

Check out the documentation here and it covers all of your questions.