Quiz not displaying as anticipated.

Normal 0 false false false oNotPromoteQF /> EN-US X-NONE X-NONE MicrosoftInternetExplorer4

I have a Quiz where the user needs to get 100%. If they don't get all correct on first attempt they get a "Retry" button. If they don't get all correct on the second attempt, they get a message saying "this is your second attempt, you need to return to Lesson 4 to review". Then they go back to Lesson 4 and get a chance to do the quiz again after going thru Lesson 4.

All works great until I get to their third attempt (directly after their review of Lesson 4).

I want them to get a "Retry" button - just like they did on their first attempt, then they can go thru the quiz again for a 4th try. After that, if they still don't get it on their 4th try, they need to be sent back to Lesson 4 again (just the same as on the 2nd attempt...except this time, we need a new layer saying "this is your 4th attempt, you need to return to Lesson 4 to review..."

  • I have added a variable that Adds 1.00 to QuizCounter when the user clicks the "Retry" button. I've got Layers for Success, Failure, Failure Second time, and Failure Fourth Time.
  • On the main Layer, I have the "Retry"
  • I've got a Slide Trigger "Show Layer "Failure Second Time" When the timeline starts with conditions that "Results 3_2.ScorePoints is Less than Results3_2.PassPoints" AND "QuizCounter == Equal to 1.00
  • I've got a Slide Trigger "Show Layer "Failure Fourth Time" When the timeline starts with conditions that "Results 3_2.ScorePoints is Less than Results3_2.PassPoints" AND "QuizCounter greater than or equal to to 2.00

I tried to upload images, but for some reason, I'm not allowed to browse my computer to find it..oh well, I hope you can understand what I need. I have to get this uploaded tonight or tomorrow at the latest so I hope someone can help. thanks, Julie

1 Reply