Quizzes Preventing Complete Course Trigger From Functioning

I published a Storyline 360 module in my org's SuccessFactors build, using AICC output. The course consisted of seven scenes: A Main Menu scene, and six content scenes. Four of the six content scenes had question bank quizzes in them as learning checks. Completion was tracked through a "Complete course trigger" added to the Continue button in the final slide of the final scene. However, the course was not completing as I had intended.

To troubleshoot, I copied each of the six content scenes into it's own Storyline project, added a Complete Course button to each one, then exported and published each scene as a standalone content objects. To my surprise, the four scenes containing quizzes did not mark complete as intended within the SuccessFactors LMS, while the other two completed just fine. To confirm, I made a copy of the master project, deleted all the quizzes, and republished in SF. Sure enough, the Complete Course trigger did its job.

This has taken up two full days of my time, and I am at my wits end. Does anybody have any idea what might be causing this? The latest republish was on my home computer, which has the most up-to-date version of Storyline as of this writing. Thanks in advance. 

12 Replies
Ren Gomez

Hi Bryant,

Sorry to hear you're running into the course completion trigger not working correctly! I appreciate you taking the time to troubleshoot and have opened a case on your behalf with our support engineers to help you sort this out!

I've shared the details with my team, so be on the lookout for a response soon. I'll follow along as well to share any relevant insight here!

Bryant Kuehner

Well, I've narrowed it down to something on the Quiz Results slides - I deleted those slides, but not the question draws, and the content object completed fine in SuccessFactors. Tried re-uploading with the Results slide, but deleted the Submit Results trigger - no dice. Meanwhile, Articulate tech support told me to republish in SCORM 2004, despite my objection that our LMS team clearly states that only AICC and SCORM 1.2 are currently supported. Of course, I responded with screenshots of the subsequent, inevitable error messages.

Bryant Kuehner

UPDATE: I SOLVED THE ISSUE MYSELF! Here's what was causing the issue:

In SuccessFactors (or at least in our build of SF), when you add a content object to an online item, there is a Mastery Score field associated with that CO. This Mastery Score is the score that the LMS tracks against the learner's quiz score to see if they have passed the quiz within the module. It turns out that, even if you are using a Complete Course trigger button, you cannot leave the Mastery Score field blank if you have a Quiz Results slide in your module. My LMS support team had been telling me to leave that field completely blank, but after some tinkering, I put a "0" in that field, re-ran my module, and it completed on the first try. 

Hopefully this is helpful to any other SuccessFactors users out there!