Re-launching HTML5 Course --No Audio

I'm trying to help a client with an issue she is having with Storyline for iPads. 

The course is published to AICC.  It is narrated and slides do not advance automatically.

The first time you launch the course (HTML5) you hear the audio; however, if you do not finish and then re-launch the course with your iPad, the audio does not play.  Not good . . .

I've verified the issue with her .story file and re-publishing the course in the LMS, both as AICC and SCORM 1.2. 

I'm using Storyline Update 2 and my iPad2 is on iOS 6.1.2.

If I publish the course to the web and then access the content from my Amazon S3 account with my iPad2, I see the same behavior.

Now here's the kicker, I load the course in the SCORM Cloud and there's never any narration.

Any ideas why the missing narration?

67 Replies
Gerry Wasiluk

No problem, Pete.  As before, appreciate the updates.

Not the first time that I've seen this and probably won't be the last.  One of the "biggies" (e.g., Microsoft, Apple, SUN, etc.) makes a change to a fundamental technology (e.g., browser, OS, Java, etc.) and e-learning content that was working just fine suddenly has problems.  Ahh, the bane of our business . . . 

John Ned

Peter Anderson said:

Yep, it looks like we're going to be able to get this one fixed before the next update; we just don't have an exact date for when that update will be released, but I suspect it's not too far away. 


Peter - your updates and expertise are greatly appreciated.  Realizing that you can't give an exact date regarding the next update, can you provide any ballpark estimates that may better help us manage the expectations of various stakeholders? (a month or two, in 3rd quarter, etc.)

Peter Anderson

Thanks for asking, John. 

I'm not privy to the specific release date information, but I'd expect to see it very soon. Until we can get you the new update that fixes this issue, you may be able to workaround it by clearing your cache:

  1. Close your mobile Safari browser.
  2. On the Home screen, tap the Settings icon.
  3. Then tap Safari in the left navigation pane.
  4. And tap Clear Cookies and Data in the right details pane.
  5. When you're prompted to confirm, tap the Clear button.
  6. Then resume your Storyline course.

Hope that helps

John Ned

For the folks encountering this audio problem - are you seeing this only when "On story restart, resume" is set to "Prompt" ?   Based on the comments earlier in this thread, it is my understanding that setting this to "Never" is a workaround, but I'm wondering if anyone has had luck with setting resume to "Always"?

John Collier

Peter Anderson said:

Thanks for asking, John. 

I'm not privy to the specific release date information, but I'd expect to see it very soon. Until we can get you the new update that fixes this issue, you may be able to workaround it by clearing your cache:

  1. Close your mobile Safari browser.
  2. On the Home screen, tap the Settings icon.
  3. Then tap Safari in the left navigation pane.
  4. And tap Clear Cookies and Data in the right details pane.
  5. When you're prompted to confirm, tap the Clear button.
  6. Then resume your Storyline course.

Hope that helps

Tried this - no luck. Also, never plays, not just when they re-visit. Works fine on the PC. Will wait for the update.
John Collier

Peter Anderson said:

John Collier said:

 

Tried this - no luck. Also, never plays, not just when they re-visit. Works fine on the PC. Will wait for the update.


Hi John, 

Are you saying that your audio never plays in HTML5 on iPad? That could be a separate issue. Any chance you'd like us to take a look at your file


Sent - thank you for looking into this.

joshua simpson

I am also experiencing this issue. I have published SCORM 1.2 and loaded to our Cornerstone OnDemand LMS. I can get audio from the course on my PC but I cannot get audio from the course on a iPad. I have also tested publishing to Articulate Online (still on my free trail) and the same problem exists when viewing on an iPad. Any ideas or tips and tricks to try to troubleshoot this issue? I am stumped, I tried clearing my browser cache, I tried Mobile Safari and Chrome. I have rebooted. Still no luck.

Thanks in advance,

Josh

Jane Jones

We are having a similar problem. The course is published using AICC and we are testing it on iPads. All pages have audio. A few pages have background music playing at the same time with voiceover audio (separate tracks). Some pages advance automatically, but not all. The course plays audio the first time through for one tester, only background music on a few slides with no voiceover for another tester, and no audio at all for a third tester. For the tester that audio played successfully, when they exited the course and re-entered it, the audio did not play. Are there any new workarounds or suggestions?

Peter Anderson

Liz Hilton said:

Hi I am having trouble using audio completion as a trigger for advancing to the next slide - It work is preview mode, but not when published to HTML5 - has anyone had similar issues?


Hey Liz, 

If you'd like, we'd be happy to take a closer look at it. Can you please go ahead and open a ticket, including the .story file, so we can take a closer look at what's going on?

 

Thanks!  

michael roddick

This tread has been quiet usfull as I too am having issues with audio on the iPad. Although there hasn't been much mention of the mobile app. I can get sound to play through headphones in the app just not the speaker. The common denominator here seems to be the device. Are there any "audio not playing" discussions regarding the app and not html5 or are they the same issue?

Peter Anderson

michael roddick said:

This tread has been quiet usfull as I too am having issues with audio on the iPad. Although there hasn't been much mention of the mobile app. I can get sound to play through headphones in the app just not the speaker. The common denominator here seems to be the device. Are there any "audio not playing" discussions regarding the app and not html5 or are they the same issue?


Hi Michael, 

Typically, the performance will be much better in the Mobile Player app than it will in HTML5 on mobile Safari. Are you able to share a link to your published course, either here or privately, so we can test it on our end? 

Thanks!

Peter Anderson

michael roddick said:

This tread has been quiet usfull as I too am having issues with audio on the iPad. Although there hasn't been much mention of the mobile app. I can get sound to play through headphones in the app just not the speaker. The common denominator here seems to be the device. Are there any "audio not playing" discussions regarding the app and not html5 or are they the same issue?


Hey Michael!!

Was just following up on your case and it sounds like you were able to get this resolved on your server's end?

Glad to hear it, and let us know if you run into any other questions

joshua simpson

Has the update to fix the resuming issue been released? I can only get playback to work consistently if I set the course to "Never Resume" which is a pain for all of our users. 

Also, will it ever be possible to have clients run the courses in mobile Safari and have a decent experience? Currently I can only get decent playback results from Chrome. Safari seems pretty limited in the support for HTML5 features.

Thanks,

Josh

Christine Hendrickson

Hi there Joshua,

We haven't released it, just yet. However, we are planning on releasing it very, very soon. It's an extremely exciting update that should resolve this issue, as well as quite a few performance issues for HTML5 content. 

While I cannot give an estimate or a list of fixes for this, we definitely plan on sharing updates once we have them. 

Keep an eye on this thread, if you can! We'll be sure to post when the update has been released.

Thanks very much,

Christine

Peter Anderson

Hi all,

If your iPad is running iOS version 6.1.2 or later, you may find that audio doesn't work when you resume HTML5 content in mobile Safari. This issue was corrected in Update 3 for Storyline. Please review the following article for more information: