Recording LMS completion with just 1 answer correct

Mar 25, 2015

Storyline 2 published to AICC works correctly in our LMS. I've tested it with standard questions and question banks and haven't had any issues.

The course with which I am having a problem is set up to require learners to get 90% correct , pulling a total of 30 questions from 3 question banks. There is a single results slide that is used to track quiz results, based on the 3 question banks. (See attached image.) I've published the course to AICC. However, when I test the course in our LMS, it gives credit as soon as a single question is answered correctly. It doesn't even get to the results slide to give credit.

My coworker and I don't know how to proceed. We have verified the publish settings. We've verified that other Storyline 2 courses work correctly in the LMS, with and without question banks. We've tried the current course without the question banks and just standard questions. We've ensured that we have the latest version of Storyline 2. We've even tried publishing on different machine. We get the same result - completion recorded in LMS upon first correctly-answered question.

Does anybody have any suggestions?

4 Replies
Wendy Jaehnig

Update: If I get the first question correct, then get the second question wrong, I will not get credit in the LMS. So, I think that a score is being sent upon exiting, and the score is only accounting for the number of questions that have been presented up to that point. Thus, if I answer the first one correctly, and then leave the course, it sends a score of 1 out of 1 correct (100). However, if I answer the first one correctly, but get the second one incorrect, it sends a score of 1 out of 2 (50). This is my hypothesis based on what I am seeing. (Unfortunately, I am not able to see what is actually being sent to the LMS.) Any ideas for how to fix this?

Wendy Jaehnig

Update: I have found the cause of the problem. One of my questions in the question pool somehow was set to branch to another slide outside of the question pool (rather than to Next, which is the default). When that was set to another slide or to Unassigned, my LMS recorded a completion upon getting the first answer correct. However, when I set the branching back to Next Slide, it worked as it should and only recorded  a completion upon passing.

I have attached a screenshot showing where the problematic branching was set up, in case anybody else has the issue in the future. (Sorry about the black boxes - confidentiality issues.)

Thanks for your offer of help, Leslie.

This discussion is closed. You can start a new discussion or contact Articulate Support.