Remote pointer navigation failure for lightbox layers in SL2

Hi

Keen for help please. I have lightbox slides with multiple layers created in SL1. Both mouse click and remote pointer navigation up and down the layers works fine. Now in SL2 the 'page down' function to progress through the layers gets to the second layer ok, but then bounces back to the first layer.

8 Replies
Nick Strapp

Hi Ashley

Very grateful for your response. The issue appears to be for the remote pointer only. 

Where a slide has a number of layers the remote pointer navigation enables progression from base to the first layer, and then to the next layer, but the third results in returning to the first layer - and it will not move from there. This occurs in both lightbox and regular slides. It appears that something is limiting the remote pointer function to two layers/clicks.

I use custom navigation buttons which enable function for mouse and remote pointer triggers. I have used these in SL1. On the base slide I have a button with a trigger - "Show layer 'x' when the user presses the PGDOWN key". On layer 'x' I repeat the button, but specifying the next layer - "Show layer 'y' when the user presses the PGDOWN key". I repeat this for the remaining layers - up to 14 layers in some cases. 

Interestingly, I tried changing the key on the remote pointer for the '3rd click' and it worked. i.e. using the same key more than twice has a problem, but by changing the key selected (PGUP instead of PGDOWN) it works - which of course if not viable, but may give a clue as to what is behind this.

This occurs when published to CD and web as well as preview.

I have uploaded a reduced zipped version of the presentation if that would be helpful to see?

Ashley Terwilliger

Hi Nick,

So I don't have a remote pointer to test this - but I talked with a few other members of our support team about next steps and they suggested to try downloading a Keylogger and watching to see what keystrokes are pressed when using the remote pointer.  Then, press the same keys on the keyboard.  Their thought is that the keys being pressed by the remote pointer are different than the keys being pressed by the keyboard.

Keyloggers can be detected as malware, so this would be an unsupported task and something your IT department may frown upon. So you may also want to check into if the pointer has any software updates available or test it with a different pointer. 
Nick Strapp

Hello Ashley

Thank you for the suggestions. I have tried two keylogger programmes, but neither is providing any additional information.

SL2 trigger wizard however links the 'forwards' on the remote pointer to the keyboard entry of PageDown and 'backwards' as PageUp. I have therefore tried using the keyboard PgUp and PgDn. As with the remote pointer, this keyboard approach has the same result: works fine to progress twice, but then fails.

I have checked that the pointer still functions correctly in SL1 files and that using the keyboard PgUp and PgDn has the same functionality - and all runs fine.

I do hope you and/or your colleagues have some other ideas?

Ashley Terwilliger

Hi Nick,

I'm sorry if I misunderstood - are you having the same difficulty using the actual keyboard keys to navigate after a third click? I am reading it as just the remote pointer is not working? If the keyboard keys aren't working as well I'm happy to take a look at this and would ask for you to share a sample file here with us that you've set up with these triggers. 

Nick Strapp

Hi

The remote pointer is my primary need, however, it links to the 'PgUp' and 'PgDn' keys which now will not enable the navigation beyond the two clicks. 

Very grateful for this being followed up. Link below is to a reduced version of the presentation:

Presentation

2 places to review the issue:

1. Underpinning knowledge (first module) - model on 'Justification should build using a series of layers, but users cannot progress after 2nd click

2. Lightbox - Core models - user should be able to access all layers via PgDn and remote pointer

Ashley Terwilliger

Hi Nick,

Thanks for sharing your project file here and some additional information to help clarify. I took a look at your file and saw the same behavior and tested it on a brand new file as well. It seems that after the second key press - the trigger loops it back to the previous layer. I've tried this with a few different keypress options and trying to track which layer to show based on a variable without success.  I was able to get to the next layer (say layer 3) if I used a different key press trigger. I'm going to be sharing this with our QA team for additional review. In the meantime you may want to look at splitting up those additional layer into new slides to allow the user to advance.