replay button resets variables & Quiz options did not random

Hi,

Problem 1:

I encounter the issue whereby when learner finishes the interactive slide and I have a trigger which shows "click NEXT to proceed" after all variables set become true. But when the learner clicks replay button after that, it seems that the variables were all reset to false. How can i prevent this from happening?

Problem 2:

In quiz slides (both multiple choice & multiple response), I have set the answers to be shuffled. The problem I encounter like below:

1st visit:
Option 1

Option 3

Option 2

2nd visit:

Option 2

Option 1

Option 3

3rd visit and 4th visit and so on... (Problem lies here: Option did not random anymore and stuck like 2nd visit)

Option 2

Option 1

Option 3

Is this bug? Please help!

Thanks and regards,

Emalyn

3 Replies
Emalyn Lim

Hi Wendy,

Thanks for the reply.

Problem 1: My issue was when I'm still within the same slide and clicking the REPLAY button, the replay system resets my variables all to false. The requirement of my project is each time revisits the slide, it has to be initial state. 

Problem 2: Im using SL 1

Thanks and regards,

Emalyn 

Emalyn Lim

And I notice that at more than 2 tries of visiting the quiz, besides stucking at the same position, when I select only 1 answer, the rest shown a correct selected state (customized state) when they are not clicked at all. My options have some customized state to show tick for correct answer. You may see from the attached test file.

I've been using the same method since UPDATE 3 and I don't face this issue at all in older UPDATE version. But when updated to version 6. I have issue all over the place.

Please help :(