Reporting multiple response quiz question to LMS

Hello,

I have a quiz with different types of questions and I'm trying to make sure all of them report correctly to the LMS (Moodle 3.1) so that facilitators can see what participants have answered.

The multiple choice and short answer questions are reporting the details and I can see the individual responses in Moodle under interaction report. However, the multiple response question only report the first letter of each of the responses selected (or so it seems...). Is there a way to change the value that is reported back for each of the possible answers? or alternatively, report back the full text of the answers?

I'm exporting from Storyline 2 in SCORM 1.2. (I tried SCORM 2004 but then I didn't get any details at all in Moodle, only the final score).

Any insight on this issue will be appreciated. Thanks!

4 Replies
Crystal Horn

Hello Aya!  This article describes the quiz data that Articulate sends to your LMS, and to include question text, you'll want to use SCORM 2004 or Tin Can API, neither of which is supported by Moodle per their site.  So I can see how this might be putting you in a pickle.  

I'm hoping to get some input from other community members as well, but I did find some information on Moodle's site for you:

"SCORM 2004 is not supported in Moodle. Parts of the API have been implemented, but others such as Navigation and Sequencing have not. Development on native SCORM 2004 support in Moodle has stopped. If you require a fully certified SCORM 2004 Player in Moodle, Rustici Software have a Moodle plugin which connects to their commercial SCORM Cloud service turning Moodle into a fully compliant SCORM 2004 LMS."
Reference:  https://docs.moodle.org/27/en/SCORM_FAQ#Supported_Versions

I would have a look at Moodle's recommendations, if they're possible to implement on your end!  Let us know how you make out.

Aya Port

Thanks Crystal! This is useful information, although we're still in a pickle... 

Is there documentation of which data will be sent in the field student_response by type of question? It's definitely working for some types of questions, just not for the Multiple Response. I'm attaching a screenshot of the report in Moodle, in case it helps. 

Another option I'm thinking of is saving the answers in variables and then trying to send these to the LMS. Do you think that will work?

Victoria Burroughes

Hi Aya,

Have you got had any success with this? I've just encountered the same problem for multiple response, sequence drag and drop and matching drag and drop type questions.

Sometimes I get the first letters for student response only, and sometimes I get first the letters for the actual correct answer, and other times I only get letters for both columns. I can't seem to find a pattern in it.

Thanks,

Emma