Reset numeric quiz

Hello everyone,

I have created a quiz as quiz bank, with multiple choice and numeric questions.

It works fine and the results slide does so, as well.

When I retry the quiz, the questions are reset, however in the numeric quiz there are still my answers from last try. I can change them, however it is not completely reset and blank.

Is this a bug, my mistake or something I can change in the settings?

Thanks a lot, best regards,

Max

17 Replies
Ashley Terwilliger

Hi Helena,

Fill in the blank, numeric entry, and drag and drop question types don't automatically reset during a second attempt of the quiz - so that the user can see how they previously answered. If you're using your "rewind" button, it will function as described here for resetting the slide. 

If you'd like it to reset always, you may want to look into adding a trigger to your feedback layers to "jump to slide this slide" when the user closes the layer using the continue button or similar. That would allow the slide to be "revisited" and then you could use the behavior of "reset to initial state" to have the user retry the quiz. It will treat it as a brand new attempt each time. 

Helene Caura

Hi Ashley

Thank you for helping with this. My client is patient, but anxious for me to find a way to make their course work properly!

The rewind button works for these slides, as we hear the audio at the beginning of the slide, but it doesn't reset the fields. So the users can't retype their answers. I can't add a trigger to the feedback layers, as most users will simply click NEXT to continue, but maybe I can try adding a trigger at the beginning of the slide, 0.2 sec before the audio starts... Will try this. 

So it is clearly a bug in Storyline, right? 

Ashley Terwilliger

Hi Helene,

The rewind button won't clear out that text as a default. The reason I mentioned the "jump to slide trigger" is normally when I've seen the question asked here, its because you're waiting the user to have a fresh start at answering the question after seeing the try again feedback. If you don't have any try again feedback with the normal continue button (which the default set up is to hide the layer) you may want to look at adding a custom button to the slide to "refresh" or "reset" the question and assign the trigger to that. 

Helene Caura

Hi again

The rewind button should reset the text, as it resets the other multiple choice questions, hot spots, etc. If I use a "try again" button it is not the same as a rewind action that they could be used to do for all the other slides, to simply start from scratch on the slide. My client just wants the Rewind button to do its job, as it does for the other slides. She doesn't want another button, because the Rewind button will still not work. It is a bug (don't know if it's fixed in Storyline 2).

I will try to add a trigger at the start of the slide to mimic the reset to initial state action that is not working with the rewind button.

Thank you for your help.

Helene Caura

Hi again

I have tried a trigger to jump to the same slide from the layer, and from inside the slide itself, but it doesn't work. It does exactly the same as the rewind button. It rewinds but does not reset. Only the "try again" button resets the page, or I have to move to the next or previous slide and come back, so that the "reset to initial state" works. Annoying...

David Burton

Helene,

As Ashley noted above, it's by design that the rewind button won't clear an input or text field. As a workaround you could try the following:

1. Set the base layer properties of the Numeric slide to 'Reset to initial state' when revisiting.
2. From the triggers panel, change:

Set 'NumericEntry' equal to the typed value when the control loses focus

... to:

Set 'unassigned' equal to a value when the control loses focus

Although the rewind button will not clear the input filed while on the slide, the above two settings in combination will reset the input field when revisiting and after submitting.

I hope this helps.

Screenshots attached:

Helene Caura

Hi David

Thank you for this post. I have tried the trick, but it doesn't have any different effect; I still can't type in a new entry after I submitted and clicked Rewind. It only works if I navigate forth and back to the slide. It's basically as if the "reset to initial state" had no effect on the numeric or fill in the gap activity.

See my file attached please.

David Burton

Helene,

I stepped outside the box on this a bit and believe I've come up with a better workaround that is relatively easy to implement. Try the following.

1. Insert a very short blank audio clip (.1 seconds) on the same timeline as your Fill in the blank.
2. Add the following Trigger:

- Set TextEntry equal to (blank) When the media completes (Make sure you select the .1 second audio clip)

The above solution will reset any Text or Numeric entry field when the slide starts or the rewind button is selected. For your convenience I attached a sample story here.

NOTE: You can create a short audio clip using any audio file, by editing in Storyline, silencing the whole clip then cropping. Alternatively, you can download one from the following link.

http://www.xamuel.com/blank-mp3s/

I hope this helps.

 

Helene Caura

Hi David

I was excited again when I saw you trick. I have tried adding a trigger for a blank in the text entry before but it didn't work; I thought this one with the media could work. But alas, same issue here: it works only because you have a Try again button. I wanted to have only one attempt. As soon as you remove the try again layer, it doesn't work. Also if you don't click COntinue in the correct layer but click Rewind, it doesn't move either.

Thank you for trying anyway! I think we have to admit that the Rewind button doesn't work like it should (=like it does for all the other types of slides) for the Numeric and Text entry activities. Basta.

Ron Franks

I know this is 3 years old, but I have a similar situation with 360. I can get the text entry fields to reset by adding a trigger to change textEntry to (blank) when the timeline starts by leaving the value field empty. Unfortunately there appears to be no way to get a (blank) value in the numericEntry trigger. Leaving that value blank results in a value of 0.00.

I've read everything posted 3 years ago above. Has something changed since then in 360 that will allow me to reset the numeric entry field when revisiting a slide?