Resources: URLs

I'm having an issue with Resources in Storyline. When I attach a document, everything works just fine. However, when I select URL, I can't get the links to open. Initially, I tried linking to a document on my company's secure intranet. When that didn't work, I tried Google. Both URLs worked when I clicked the Test button, but after publishing, nothing happened when I clicked on either link. When I right-clicked, there was no option to open the links; I just got zoom in and out and about this version of Flash player. I've tried publishing for Web and LMS, and I get the same results either way.

This particular "course" is actually just a demo that will launch from our intranet, so I have not uploaded it to our LMS. In fact, I have not uploaded it to our intranet yet, because this issue arose when I tested the demo after publishing. I'm using Internet Explorer, so I'm pretty sure we can rule out interference from the LMS, the intranet, and the browser. Any suggestions? Thanks!

7 Replies
Jeanette Brooks

Hi Ryan! So you're viewing the content locally when you test it? If so, that is likely the issue, because viewing local content when you've published for web or LMS will often cause problems with resources opening properly, because of browser/security restrictions. Can you try uploading your published content to the web or to your LMS (whichever you published for), and then test it to see how things work?

If you don't have an easy place to upload & test, you can use Tempshare - it's a free and simple method to temporarily host your content so that you can see how things behave.

Florian Ripper

Have a simple issue (well.. simple for explaining it): At a published Story I can't access URLs via the Recources tab.

As at Ryan above, the test passes after entering the URL - the intranet page is displayed - as against the published status where the resource is showing up but doesn't reply to my click command. So I can click at the link but nothing happens.

Any solution proposals? Thanks!

Christine Hendrickson

Welcome to E-Learning Heroes, Florian!

Have you had a chance to upload your course to a web server or LMS before testing this? If you view published Storyline content on your local hard drive or send it to someone else to view on their local hard drive, you'll encounter security restrictions from the computer, web browser, Flash Player, and network that'll cause various features of your content to fail.

To properly test your published content and share it with others, upload it to the environment for which it was published. Please review the following article for details:
If that doesn't help, are you able to post the .STORY file here, so I can take a look? You're also welcome to send it over to us privately, if you prefer. 
Thanks!
Christine
Denise Gaul

Hello Storyline,

When I publish for LMS, the URL in the Player Resources does not appear when I test the module in our LMS system. 

When I preview the module, the URL appears in the Player Resources and the link works - takes me to the document on our server.

In the LMS version it isn't that the link doesn't work, the link does not even appear.  Can you help?

Thank you, Denise