Responses not saved in Storyline 1

Hi we are using Storyline 1 with Moodle 2.7.

For one of our SCORM packages that contain open-ended text questions, some of our students' responses are not saving. The SCORM is set to unlimited attempts, do not force new attempt, and do not lock after final attempt. Any ideas why some students' responses are not saving?

Thanks

11 Replies
Alexander Salas

I would suggest testing your module on SCORM Cloud to rule out Moodle as the culprit.  As far as SL1 settings, what are you publishing to? 1.2 or 2004? Are your SCORM settings tracking by a result slide? In this case would want to make sure your result slide includes all desired questions.  If you can share the .story file I can help.

Jasmine C

Hi Ashley,
they are not saving when we view the results both on the slide itself, and in the LMS. When you refer to the revisiting properties for the slides, do you mean Moodle settings such as "Force completed" (this is a now a Yes) and "Force new attempt" (this is now a No)? What should the settings be in order to prevent resetting their entries to a blank value and submitting that as an option. We do need them to be a No for "Force new attempt" because some students may not be able to complete the entire module in one sitting.
If that's not what you mean re revisiting properties, please describe specifically where I can find and set those settings up.

Hi Alexander,
re SL1 settings, I'm publishing to 1.2. The SCORM settings are to track by result slide and it includes all desired questions. The file is attached here.

thanks so much

 

Dan Marsden

the SCORM 1.2 specification sets some limits on the allowed length of some of the values and open ended questions can frequently end up going over this limit. Moodle 2.7 and higher versions contain a setting that allows Moodle to store longer values but most SCORM packages truncate or modify this data before sending to the LMS as well so it may require a change within your Package as well. (others here should be able to advise on this)

The Moodle setting is called "scorm12standard" and can be found by going to  admin > plugins > activities > SCORM - if you un-tick that box it will allow Moodle to store higher values.

Alexander Salas

Hi Jasmine, it looks like this is the published file and not the .story file. However, I preview this and the fields are holding my text entries.  So @Ashley was mentioning the slide properties in SL which allow you to "reset to initial state when revisiting" or automatically decide.

It's to troubleshoot the source file but, I can understand if you can't share it. 

Jasmine C

Thanks Dan, Ashley and Alexander, your help is all VERY much appreciated!

I've now done the following:

1. Reset in Moodle SCORM as recommended
2. Correct the SL slide properties as recommended

I am still testing and will get back on the verdict whether it is Moodle related.

Have a great day,
Jasmine