Responsive Player Settings Not Working

For Articulate Staff: Case #00990363

We are wanting to change the settings in our modules so that on mobile devices, they can only be viewed in portrait mode. With these settings, published files work on SCORM cloud and when the device is turned to landscape orientation, the message appears on-screen, "Please rotate your device."

When the same published files are launched in Moodle, no messages appear. Has anyone else experienced the same issue with their LMS?

7 Replies
Alyssa Gomez

Hi there Tiffany,

I'll defer to the community for their experience with this type of issue, but I did want to share an update on your support case. I see that Victor confirmed the behavior you described, and it looks like he is doing further testing to see what's causing the device notification not to appear when hosted on Moodle. I'll check back in and post updates here as they are available!

Jacob Villum

It used to work on our LMS system, but now it does not. You also state that you have solved the player chrome issue for Safari on mobile. But browser bars on top and below still eats away 20% of the screen preventing the user to see and click on contents blocked by the browser bars. It is a mayor issue! Please solve it fast! And yes my iPhone is updated with IOS 11.2.5.

Steven McAneney

UPDATE - IT WORKS! I changed my player settings to "Resize to full screen" and the responsive player works fine on both Android and iPhone. I did find that iOS Safari is a little too smart for its own good, and sometimes toggles out of full screen mode when the user presses buttons within the e-learning (this is what's happening to Jacob I think). I have minimised the inconvenience this causes by making the e-learning buttons as large as possible, and adding a topic to the help menu telling users to flip their phone to portrait mode, then back to landscape. This resets the phone to full screen. That's what you have to put up with when using a browser to deliver content, instead of an app I guess!

Jacob Villum

Hi Steven.

Thx for your reply. But it does not work for iOS Safari, the way it should. If the user touches the top or the bottom of the screen, the bars reappear, and it is not a good solution that I tell the users to "Flip" their phone when it happens. And this only works if you publish your e-learning with a launch page. But the launch page is a really bad solution because of the popup blocker in all browsers. So I publish it without the launch page, and when I do that, the browser bars are there by default and no "flipping" changes that. And I will not have to put up with it, since Articulate has said it would work. I have sold this solution to an important client, who is not happy.

I really hope, that Articulate fixes this issue fast.

Best

Jacob

Steven McAneney

Jacob, I don't see this to be an Articulate issue. It's the way Safari handles full-screen. I don't see how any modification to Storyline is going to change that.  Some other users have gotten around this by adding a screen to the start of the course telling users it should be viewed in landscape mode. You might actually be able to add some Javascript to pull the OS off the LMS and only display the "landscape" message for appropriate devices. 

Rise by Articulate is more suited to mobile devices, but I haven't used it yet. The best option would probably be an App. But how many apps have you downloaded that don't work properly? 10's? 100's? Even they have their problems.

Testing is the key here. I spent an hour or so testing on different devices, and now I know what to expect BEFORE I roll my 40 mobile 'compatible' projects out (notice I say "compatible", not "friendly"). 

I hope you work it out.