5 Replies
sharon amer

Hello Wendy,

Thanks for your response. I am using the %Results.ScorePercent% 

I am not combining the results. At this stage I just want them to pass the quiz 1 then move on if they do, so I am resetting the results slide on 8.2 before they take the second quiz.

Please see attached

Wendy Farmer

Hi Sharon

each time you add in a result slide SL automatically creates the four result variables.  You have two result slides 3.7 and 8.12 and each result slide should have it's own set of variables.  Slide 3.7 is correctly reporting Results.Score and Slide 8.12 should be referencing Results1.Score.

I changed your file to reflect the results1 variables but it still returned a 0 score. Then when I checked the triggers again it had reverted to Results.Score variables which are being used by slide 3.7.  I think the result slide may be corrupt.

 

I then added a new result slide referencing those 9 questions and it worked as expected. I'm not sure why it's not working. I would recommend moving the existing 8.12 result slide to a scene that isn't being referenced and insert a new result slide that calculates the 9 quiz questions - remember to change that on your publish settings to the new result slide.

Sorry I couldn't be more help

sharon amer

Thank you Wendy! My suspicion was that it was corrupt, so you have confirmed my thoughts.

I have reverted back a version imported the quiz 2 again without the results slide and then just created a new results slide from scratch. Quite a faff! but avoids having numerous results slides in my course.