Results Slide Variables - URGENT

Hi Everyone,

So I have a results slide (inserted from the inbuilt quizzing templates) but for some reason I don't have the four variables I was expecting to see ie

Results Pass Points

Results Score Points

Results pass Percentage

Results Score Percentage

The only one I have is Results Score Percentage. I desperately do not want to recreate the results slide so I need to know:

1: will the LMS read the quiz as complete if all I have is the Results Score Percentage variable

2: if I manually create a Results Pass Percentage variable (using the variable wizard) will the LMS recognise it?

This is really urgent as, if the solution is to rebuild the slide, it will take me approximately 1 day to do it (it's kinds fancy) and the project deadline is this week.

All help and suggestions much appreciated.

Harri 

30 Replies
Michael Hinze

I'm not sure I understand the issue. Inserting a Results slide (no matter which of the 3 built-in styles) automatically creates the four Score-related variables. They may not be displayed in the Results slide, but they are there and will be used for reporting. See below a screenshot,; even a blank Results slide generates the score variables. Are you saying that you don't see these variables in the Variable editor window (as far as I know they can't be manually deleted and they certainly can't be manually created or edited).

Rebecca Fleisch Cordeiro

Hi Michael,

I've actually seen the same thing that Harri is describing...when going into the Variables Editor Window did NOT show the 4 Results variables. Only 1 appeared. The other 3 were MIA.

I don't know how it happened, so I can't recreate it. In my case, I inserted a new Results slide and simply copied/pasted my customized stuff onto it. That was the only way I could get all the Results Variables back. Well, I didn't get them back. New ones were created.

Rebecca Fleisch Cordeiro

Nope. I couldn't/can't recreate it either. But it DID happen to me. I can totally see that Editor Window with only the one Results variable in it and me trying to poke around to find where the others all went . (and why I can't get the extra ones to go away when I want them to ;-))

It was a few months ago and has only happened that one time.

Harri C

Hi Guys,

I have absolutely no idea how this happened but I can confirm that I was looking in the variable editor window. Unfortunately I can't copy and paste the custom content because when I try it crashes SL (it's a scroll panel with lots of boxes in seems too much for SL to handle).

What I'm going to attempt to do is insert a new results slide and change the variable on my current results slide to reflect the new one.

I'm going to be testing this work around this morning and I'll let you know how it goes.

Thanks for all your help 

David Tappenden

Hi Leslie,

The work around I used above now is not working! :(

 

I am desperate to get some kind of solution to this problem as I need to create a number of other quiz slides and have a deadline for a project I am working on. Can anyone help? 

The rebuild  Harri suggested wont work as there is no way I can recreate the variables and bring them into my current project.

 

Thanks!

David

Anneleen Tulpin

Hi, I have had a similar, or maybe even the same, issue twice in a few weeks now. Resultslide is looking fine, all variables are there and then...all of a sudden, the built-in variables disappear on me! Can somebody please tell me how this is possible and more importantly... how do I fix this!? I'm working on the latest version of storyline 360 btw ;-).

Alyssa Gomez

Hello, The Learning Hub NV!

Thanks for reaching out -- we definitely don't want your results slide variables disappearing on you! This isn't something we've been able to recreate in a new Storyline 360 file, so it sounds like it could be file-specific. Would you mind sharing your file with our team here so we can have a closer look? Thanks!

Leslie McKerchie

Glad you were able to find a way around the issue you were experiencing Anneleen.

The only thing that comes to mind when I hear of unexpected, erratic behavior like that is corruption, so I wanted to share some ideas on prevention in case they might be helpful for you.

File corruption is unpredictable, and there's no straightforward way to determine what causes it. Common causes are environmental (disk errors, power outages, improper shutdowns), viruses, failed Windows updates, and even file size (i.e., very large files have a higher risk of corrupting). 

Consider these preventative measures to protect your project files: 

1) Save and publish projects on your local hard drive. Working on a network drive or external USB drive can cause erratic behavior due to latency. 

2) Save incrementally. If your app has an AutoRecovery feature, take advantage of it. If not, save a new version of your project every hour or so with a new file name each time. If a file becomes corrupt, you'll still have a working version available. 

3) Install Dropbox. Snapshots of changes in your local Dropbox folder are kept for 30 days. If a file is damaged or deleted, you can restore a previous snapshot.

4) Don't leave the app open and unattended for long periods of time. Some users have reported file corruption after leaving their apps open overnight. It's possible that a malware scan or disk backup could run because the machine is idle, making your app vulnerable to crashing.
Lisa Ferris

The dreaded Disappearing Results Variables has happened again.  Given that I have multiple modules to create I need to get this resolved.  Problem is the same described above.  I create a Results slide, add the user's score thing, but there are no Results variables in the list.  When I preview the quiz, it doesn't give a score.   I just upgraded Storyline.  I've tried multiple new results screens.  No luck.  I'm attaching the file and the evidence :)  Hopefully, I'm doing something not intelligent that's causing this. Thanks!

Leslie McKerchie

Hi Lisa,

Thanks for that image as well as a .story file so that I could take a quick look.

I was able to add in a Result Slide to your course and the variables were included. Here's a quick Peek 360 video.

Can you let me know if you're using a certain template or how you're adding the Result Slide? I'd be happy to take another look.