31 Replies
Alison Coops

Hello, my question is related, but not the same.  I have a bank of 15 questions.  I am drawing 10 questions.  1 of the questions is not 508 compliant and I've added a link to it to go to compliant questions instead.  Currently these (It took four multiple choice questions to test the same information as one matching drag and drop) are not in a question bank (since I expect them to answer all 4) but in a scene by themselves.  The link to the accessible questions works.  The question is "What then?" If I link it back to the "draw from question bank" slide, it shows the questions I already answered. Is there a way to get it to the logic of the question draw? (Have they answered 10 questions yet? If not, draw another question.  If so, display results slide.) Thanks.

Ashley Terwilliger

Hi Alison,

I haven't seen a set up like this, and there isn't a way I know of to "hack" the logic of the question bank. Have you looked in the Building Better Courses side of ELH and see if there is anyone who can help? That side tends to focus more on design and how to, and lots of folks who may be able to offer ideas!

Josh Santy

We are currently working on a complex exam with 3 question banks that in total requires the user to answer 100 questions total from the 3 banks. The problem I am having is that when exiting and re-entering the exam, it isn't consistent in where it places me back in the exam. It could be 4 questions before the question I left, or it might start me over from the beginning.

Any ideas of why this might be happening?

Ashley Terwilliger

Hi Josh, 

It sounds like you're running into issues with the resume data? What output type did you choose when publishing for LMS? Does this happen regardless of what point you left the course, or are you seeing it after reaching a certain point each time? 

I would also suggest testing the course in another environment, such as SCORM Cloud. That'll help narrow down where the issue is! 

Ashley Terwilliger

Hi Josh,

Thanks for doing that additional testing! I think we'll need to take a look at your course, with your permission of course, as than our team can test and investigate the various settings that could be impacting this.

I'll open a Support case for you, and you'll see a confirmation email shortly where you can upload your .story file and share a link to the course in SCORM Cloud too. 

Michelle M

I have had the same issue as Josh - did you get to the bottom of this?

I have 5 question banks, from which a random selection of 10 questions are asked. I have the course set to "Always resume". I have uploaded it to my own LMS system to test it. When I exit the course after 9 questions, and re-launch it, it starts the draw of 10 again, rather than resuming from the last question.

 

I actually want the course to resume where it left off, but not calculate the score correctly if they have left the course partway through the quiz.  I am trying to force people to do the quiz all in  one go

 

Michelle M

I have just double checked - when I complete the entire quiz and purposefully fail, it still resumes at the start of the quiz when I relaunch it. This is the worst of both scenarios - I essentially need users to be locked out if they fail the quiz, and not be able to reattempt it without intervention by a member of the eLMS team.

Leslie McKerchie

Hi Michelle,

I took a look at Josh's support case, but do not see a resolution to share with you.

Are you running into the same issue in SCORM Cloud as well?

With your permission, I'd like to take a look at your project file to investigate what's happening. You can share it publicly here, or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.

Michelle M

Hiya, I submitted a query to my local articulate vendor with this issue, they had a look at my file and this is what they came back with:

"The Result slide had a trigger that submits the result to the LMS and it only submit the suspend data when the timeline on the result slide start and hence why the quiz has to be taken in one sitting."

 

However, they did not provide any solutions! :( Does anybody have any idea of a workaround that would meet my needs, or how to alter the submit behavior?

Alyssa Gomez

Hi Michelle!

This certainly doesn't sound like normal behavior. Storyline doesn't force the learner to take the entire quiz in one sitting, and the quiz should resume where the learner left off.

If you don't mind sharing your file, we can take a closer look to investigate what's happening. We'll delete it when we're done troubleshooting. If that works for you, you can upload your file privately to our support team here. We'll give it a test and let you know what we find!

Michelle M

Will do Chris. So far support has asked me to test the item in SCORM cloud and see if the issue occurs here, to rule out any problems that may be due to my particular LMS system.

The issue does indeed occur in SCORM cloud and I've notified Wilbert (articulate support) of this. I'll keep this thread updated with any further progress.

Leslie McKerchie

Thanks, Chris. If you need our team to take a look, you are welcome to share as well. With your permission, you can share your project file with our support engineers to investigate what's happening right here. It will be deleted when troubleshooting is complete.

Looks like Michelle is already doing a fantastic job of keeping us up-to-date on her case. Thank you :)

Agnieszka Gorgon

Hello everyone,

I am running into the same issue with my assessment. 

The assessment is set up to present 90 questions, drawn randomly from 24 question pools. Upon resume, the assessment jumps back to a random question at the beginning of the assessment (sometimes question 6, question 10, question 16).  Questions that had previously been answered are presented as new, unanswered questions. 

The assessment is published to SCORM 1.2, but the same behaviour persists when published to SCORM 2004 Version 4.

I have another, a much shorter assessment that presents 25 questions, and the same problem persists here. A maximum of 12 questions are retained. 

I submitted a case to Articulate support, but since found this thread and wanted to see if there has been any resolution to this problem. 

I am running into this behaviour in our LMS and on SCORMCloud. See preview on SCORMCloud.

Thank you for any additional information on this issue.

Agnieszka