Resume not working properly in LMS, jumps to wrong slide

Hi, I've been struggling with the resume function after publishing it to Scorm 1.2 and uploading it to LMS. It seems to not properly track where I exited the course and when I log back in, it jumps to a quiz slide that I had already finished and loses all the progress I had made with other modules. 

A few things:

- The same issue appears when I uploaded it to Scorm Cloud
- Resuming works perfectly fine on the iPad with the Articulate app
- When I publish it to Scorm 2004, the problem does not occur either, however with Scorm 2004 a lot of the layouts get messed up, so that's not an option either.
- The course exists of 14 scenes and 187 slides (with a lot of slide layers)
- I'm using Storyline 2 (the first half of the course was built in Storyline 1 and then converted to 2) 

There is quite some rush to get this course online, so I really hope someone can help me with this. Any suggestions are welcome!  

Thank you!

Jacqueline

22 Replies
Veronica Budnikas

Hi Jacqueline,

When you publish to SCORM 1.2, does it always jump back to the same quiz slide? If so, it could be a problem with the version of SCORM you are using and the suspend data limit.

Possibly look at this: http://en-au.articulate.com/support/storyline/exceeding-scorm-suspend-data-limits

And if you need to, you can submit a support case to Articulate, they are awesomely:

http://en-au.articulate.com/support/contact/submit.php  

Good luck!

Stephanie Powner

Hi 

I am seeing exactly the same thing with a course I have published a number of times without issues before - though i have changed a couple of aspects of the content I haven't changed any of the the tracking/quizzing elements.  I have submitted a support case and will let you know my progress with this. Thanks.

Kirsty Grolimund

I am having this issue too. I am using SCORM 1.2 and currently testing on SCORM Cloud. I have a large module with two quizzes in with their own results slides. The overall result is tracked on a third results slide which averages the two scores.  The course was created in Articulate Storyline which I am using to complete the module although I now have Storyline 2 loaded to my laptop now as well.

At the moment I complete quiz one and exit the course (all the results slides are set to Resume Saved State), when I return to the module, the slide I see is one from the first question bank and instead of asking me all of the questions in the bank (22 in total) I am asked about five and the score increases from my previous score!

 

Jacqueline Xie

Thanks for all your suggestions! The course is up and running! I indeed suspected that it had something to do with the suspend data as our course is quite long. I tested it in SCORM cloud and with Stephanie's tip of setting max suspend data to a higher number (40960), the problem was resolved! (Thanks Stephanie!) However, the LMS doesn't support SCORM 2004 and it wasn't an option to reduce/split up the course or to remove any interactions.

So I did the following to reduce tracking data; I set all of the slides (including quiz slides) to "reset to initial state" (except for the result slides, as the course tracks your progress by ticking off the modules you've done). When in review mode however, the questions would then be considered 'incorrect' because there was no answer saved. To conceal this, I've added a rectangle (same color as my slide background) on the review slide that covers up the bar on the bottom. To help the student, I checked "show correct/incorrect answers".

After these tweaks the course was resuming smoothly. A small issue that still remains is that when people exit the course halfway a quiz, and log back in, the answers that they had already given before will be 'forgotten' and thus not taken into account on the result slide. However, most people will do the quizzes in one go and otherwise they will just retry the quiz.

 

 

Meredith baker

I have published working drafts to http://kidpower.articulate-online.com/.  These are interactive "games"/workbooks for children.  I expect children not to always complete the whole game in one sitting.  When resuming, the scores are accurate, but the slide layers do not display correctly.  I have set all the layers to "resumed state".....  I am using Storyline 2 and published to articulate online - using that as a trial right now.

I don't know what I am doing wrong!  Thank you for any help!

Leslie McKerchie

Hi Meredith! I apologize for not getting back with you, but the forums have been swamped lately and this is more of a how to design question than a technical one. 

Since the layers are dependent on the variable changing, this is probably why it is not resuming as expected. 

I'm hoping someone in the community will be able to further assist you with your course design.

Veronica Budnikas

Hi Meredith,

Sorry it took me so long to have a look at this.

I am looking at your file now, and it seems that the layers are not set to resume saved state, but rather they are set to automatically decide. This is slide 18.1 as an example:

Also, on this same slide, the base layer is set to reset to initial state:

I would suggest that you go through every slide and layer and check the settings again, and then test. If you are still having issues, please post an updated file and I would be happy to have a look again.

Hope this helps, Veronica

 

 

Meredith baker

Hi Veronica, thanks so much for taking time to review my file.  Sorry, I was playing around with settings before I attached it trying to see if it made any difference.... so some of slides had the initial state..

I made sure all the layers were reset and it did not work.

I finally found the problem and it was not related to "resumed state" property.  But I am not sure why this fixed it..... I am wondering if anyone knows why this fixed it?

The slide you show above is the question slide and I have it linked to an incorrect lightbox slide and a correct lightbox slide.

The problem was in the order of button triggers on each of these feedback slides.  I have a number triggers associated with updating variables when the user clicks the OK, Do Another or Try Again buttons.  On all of them I had a "Close Lightbox" trigger followed by "Jump to Gameboard")  Once I reversed the order of these two triggers, everything resumed state and all is well.  Here is the link to working game.....http://teachersagainstcancer.org/grade5catalog.htm

Thank you for your help!

Meredith

Meredith baker

Veronica,

I am learning quite a bit from this forum and experts like yourself!  Thank you for all your posts and sharing your knowledge!!  I have never worked in Articulate before this....  I have so much to learn!  But I really like this software!  And this forum is great!

Thanks for everything!

Meredith