Retry Quiz button doesn't work

I have a results slide with the Retry Quiz button. The two variables that should be on that button are there (reset quiz results and jump to slide that starts the quiz). But only one trigger works - whichever one is on top in the list. Either the score gets reset to 0 but I stay on the results slide, or I go back to the quiz but my previous answers are still there.

Based on comments in another thread, I tried putting the button on only the failure layer (which actually is where it should go!) but that didn't solve the problem.  Ideas??

If it matters, I'm using a draw from a bank for the questions...

3 Replies
Sheila Bulthuis

Well that was weird. Due to the client's proprietary content, I created a "clean" version that only had the quiz, with only four questions. I then published it to make sure I hadn't broken anything in the process and... now it works!

The only thing I can think of is that before I was publishing only the one scene with the test (the course is huge) and now with my mini version I published the whole course. That shouldn't make a difference, but it's the only thing that's different...