Review feedback layer styling

When I make a question in Articulate Storline with some Post-Quiz Feedback, the feedback text appears in a blue roundrect witha gradient and some other styling. 

When I go to the corresponding feedback master and select the "Review feedback layout", this blue roundrect is nowhere to be found. Any edits I make to this master layout do appear on the feedback layers on my question slides, but the feedback text is still in the blue roundrect

p.s. none of my feedback masters even uses the color blue...

29 Replies
Christine Hendrickson

Hi Hugo,

If you select that blue rectangle while you have the "Review" layer open (as you did in the first screenshot), you can adjust the formatting by using the options along the top menu of Storyline. 

For example, if you want to change the color of the rectangle, apply different shadows, etc., you can do so by clicking on the "Format" tab when you have the object selected. 

You can do the same with text formatting through the "Home" tab, when you have the rectangle selected.

if you have any trouble with this, please let me know.

Thanks!

Chad Cardwell

Christine Hendrickson said:

Hi Hugo,

If you're going to use it multiple times, you could simply delete the one on the Review layer and pull it through with a layout.

Or, you could even copy and paste the object - that would save some time as well.

Thanks!


Christine, do you know if this has been logged as a bug? I'm using Storyline Update 5 and it's still present.

It's quickly reproduced by creating a new blank project, adding a new question slide, adding review text on that question slide's settings, and then looking at the newly created Review layer. It will be formatted exactly as Hugo's screenshots show, and no amount of modifying the feedback master seems to change the formatting of what appears in slide view or runtime.  Yes it's possible to change it after the fact, but it still seems like a bug.

Rebecca Fleisch Cordeiro

Hi Pierre,

I've found that you can change the typeface, but not the color IF you simply try to change the color using the Format Shape Fill for that rectangle on the Review Feedback layout in the Feedback master.

As Ashley points out above, the Design themes or Theme colors controls this color.

On the attached, I've changed Accent 1 to green in the Design theme. You can access this by clicking

  1. Design tab
  2. Colors drop-down
  3. Create new colors

The problem is, Accent 1 controls other colors as well, such as the option button color and the default shape color.

I also tried moving the default rectangle offscreen and inserting my own placeholder on the Review Feedback layout but as apparently happened to you, it doesn't display when the quiz is reviewed.

I left it there for now...you'll see it on the Review Layout in the Feedback master...it has red fill and is sitting on the slide.

Not sure if we should submit a feature request. I'm sure Ashley will let us know!

Ashley Terwilliger

Thanks Rebecca for sharing the example and information here. I took a look at your file and saw the text box you added to the review feedback layer and how it wasn't on your Review layer. I added a new question slide and created a review layer for it from the "Edit question" setting and that one automatically included the red text box and the green button. I'm trying to think of what I could have done differently to have seen it behave like that compared to what you did...

Pierre can you let us know how it behaves when you open this one?

Rebecca Fleisch Cordeiro

Howdy,

Tx to both of you for replying. So, what happened is, I'd expected SL to automatically apply that review layer to any existing questions...but, it apparently didn't. Because Ijust now

  • Opened the file now
  • Clicked to open the Review layer
  • Right-clicked in the slide area to bring up a shortcut menu
  • Selected to apply the Review layout

and...voila!

So, no bug....although I WILL say that I believe SL acts inconsistently in terms of applying new layouts. It seems to me that it sometimes does so automatically, but not other times. Still, knowing this, I should have checked that before posting.

Glad the color change is working, Pierre, and that you posted, since other community members will benefit.

Terry Bell

This is surely a bug.  When I alternate between the review layer and the base layer, I have completely different themes available to me.  I tried saving my customized theme while viewing the base layer, then switched to the review layer and opened my saved theme using "Browse for themes".  This messed everything up (including my base layer color scheme), but still DID NOT RESET THE COLORS ON MY REVIEW SLIDE!!!  (even when I reset the layout)

In the past, I have given up trying to get SL to do this automatically, and I just wait until my whole exam is complete, then use the formatting paintbrush and do them all manually.

That is a pain, but it works.. at least until there is a fix for this bug.

Fiona Macelli

Ashley, I see this is an old post but what did you mean by "dragging it offstage within the feedback master"?  I'm trying to do the same thing - customize the placement, font style, font size and color of the post-quiz review caption using the feedback master. Changing the placeholder's position seems to work, but I can't change the background color, or remove the shadow effect on the font, or change the font size (using the master). It does of course change if I edit each slide.

 

Ashley Terwilliger

Hi Fiona,

This was for Storyline 1, where you couldn't delete the continue button off the feedback master but you move move or customize it. By dragging if offstage I mean moving it outside of the slide set up - so that it's visible to you while editing but when previewing or publishing the course the slide section is all that's visible. You can read a bit more about this here and watch a video. 

Fiona Macelli

Thanks for the reply Ashley but I'm still not clear how to customize the font style, font size and color of the post-quiz review caption using the feedback master in Storyline 2. I've been able to change the caption's position using the Review feedback master, and I was able to change the default color of the caption by setting my default shape to be a new color (using the Set As Default Shape command), but try as I might, the font is coming in too small and with a shadow effect on the text that I don't want.

I can change each one manually, but shouldn't the font size and style I've set in the master be carrying through to the slides?

 

Ashley Terwilliger

Hi Fiona,

Are you using questions with "feedback by choice" perhaps? I know of an issue where changing the font size on the feedback master doesn't apply to the layers when using feedback by choice, but the standard feedback by question works as expected. 

Captions also by default do have a shadow effect to text, but you should be able to remove that. If you have a sample .story file it may be easier to see what you've set up and how it's behaving to try and see if I can recreate the steps - or detail here the exact steps you're going through. 

Fiona Macelli
  1. New file (Storyline 2)
  2. Change Review master to the position, color, font, etc that you want
  3. Insert a question slide
  4. Write in the question text and include post-quiz review text.
  5. The formatting does not appear as you've set in the master.

If you first set the default shape style to be the color you want, the background color will change but it doesn't get rid of the shadow.  In this file, the font style is aligning to the master, as is the size, but not the color and the shadow effect is still there.  In my other file, the font-style and color aligned with the master, but not the font-size, and the shadow effect is always there.

Don Griesheimer

Fiona, 

I am having the same issue with my Feedback Master. I can control everything by the font shadow effect. 

The work around, which I don't deem acceptable, is to format the feedback layer per question. However, my storyline file has 234 questions. The work-around is really not an acceptable process.

Christie Pollick

Hi, Don and Fiona -- I searched in our ticketing system and was not able to locate a ticket for Fiona on this matter, so I do not have any additional suggestions to share on her case from our support team. If you'd prefer to work with our Support Staff, Don, here is the form you would need to do so and I will be sure to follow along with their progress. 

Kendra Kernen

Just wanted to chime in and say that I have consistent problems with the Feedback Masters, often with the Correct/Incorrect masters, but always with the Post-quiz Review formatting. No matter how many times and ways I reformat the Review slide master, my actual Review slides do not change. They stubbornly refuse to be anything other than the blue box with white shadowed text. (BTW, I had the exact same problem when I used QuizMaker.) I usually end up doing as Terry Bell did: just carry on with the quiz until everything is done, then go through each one with the Format Painter.