Review quiz - navigation

I'm having an issue with the 'Review Quiz' button: when they click it, it goes to the first question that they answered (see photo) so that's working fine.  However, there doesn't seem to be a way to navigate to the next question answered: when they click 'next' on the slide in the image, it goes to the next slide in the e-learning rather than the next question; when they click the 'x' on the 'Incorrect' box, nothing happens apart from them closing the 'incorrect' box.

What am I missing? Any ideas?

Thanks,

Rachel

19 Replies
Rebecca Fleisch Cordeiro

HI All,

I saw in another thread that the workaround in that skip content slides Screenr doesn't work for SL2. I've come up with a different workaround for SL2 that seems to do the trick. Uploading a story file here. 

Again, the goal is, on REVIEW, jump directly to quiz slides, skip content slides. Here, The "skip" trigger is placed on the content slide immediately following the question slide, and is set to jump to the next QUIZ slide when the timeline starts IF the T/F variable = true.

May not make sense if you haven't seen the Screenr ;( - if I get time I'll try to do another instructional video. In any case, here's a new file (with a few fun Octoberish images).

If anyone has a chance to take a look, please shout out with any questions - or corrections!

Cynthia Malone

I've been reading through this thread and have a similar question. Will this "review quiz questions - skip content" method work when you are using a question bank for an assessment? I have created a question bank of 74 questions. The actual questions drawn will be 50 out of the 74. I'd like to have the students be able to review their questions after they have completed the assessment.  Will this "method" work for this type of scenario? 

Leslie McKerchie

Hi Cynthia,

Thanks for reaching out and sharing your concerns.

The issue above was specific to individual questions dispersed within the learning content.

If you are using a question bank, I would assume that you have some learning content and then your assessment, correct?

If you utilize the built-in review quiz option added via the Results Slide, this should work as expected and navigate to all relevant slides answered by the learner.

Let me know if I've misunderstood or if you have an issue you're currently dealing with and you need us to take a look.

Sue Blanchard

My problem is a lot less complex.  I created a submit button to get people through a 4 consecutive question quiz and that works fine, but when you go back to review the slide using the built in Review Slide, the submit buttons are still there (which I don't want) and no real nav to move them to the next question in the review.  I'm sure there is an easier way but what I thought of was having the submit button go away and be replaced by just a next button.  Any advice?

Leslie McKerchie

Hi Sue,

You're absolutely right. 

It sounds like you've set it up correctly since you mention reviewing the quiz using the built-in option. By Review Slide, do you actually mean a Review button on the Result Slide?

With your permission, I'd like to take a look at your project file to investigate what's happening. You can share it publicly here, or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.

Sue Blanchard

Hi Leslie,

Yes, sorry for the wrong jargon, I did mean the Review button on the Result slide. I actually figured out that issue by adding a separate layer and changing the submit button to a next button.  The only pending item I see is after the results slide is presented and the student has the option to review the quiz, the previous and next buttons re-appear.  I would like them to stay gone and can't seem to figure that out.  Can you help?  I have uploaded the story file.