23 Replies
Corrine Kuhl

I have the same problem Maggie originally had, but deleting & recreating the Results Slide didn't fix it.  So I have a results slide with a review option - after I review the quiz when it gets to the last one and I click next, it is stuck and doesn't know where to go.  There's a next button on the slide, but clicking it doesn't do anything.

Ashley Terwilliger-Pollard

Hi Corrine and welcome to Heroes! 

Sorry to hear that you're experiencing the same behavior that Maggie had. Have you confirmed that you're following these guidelines for working within Storyline:

  • Work on your local drive (your C: drive).Working on a network drive or a USB drive can cause erratic behavior, includingfile corruption, loss of audio, and other unexpected behavior. 
  • You should also make sure the directory pathto your project files and your published output is less than 260 characters(for example C:\Articulate).
  • Avoid using special characters, accents orsymbols in your file names.
  • Are you using update 4 of Storyline? 

Also, is this happening in only one Storyline file? If so, you may want to try importing it into a new project to see if that resolves any issues with the file. If you're able to replicate this across multiple files I'd suggest conducting a repair of Storyline. 

Corrine Kuhl

Thank you Ashley.  I was on Update 3, not 4, but otherwise was good on your other 3 bullet points.  I installed the Update 4, which actually required a full uninstall and reinstall with manual activation.  But I'm still having the same problem, and this is on all my projects.

Any other ideas?  I've uploaded a module in case anyone can take a look.  Thanks!

Ashley Terwilliger-Pollard

Hi Corinne,

Thanks for sending along your .story file. After reviewing your file I see now that your Results slide is in a new scene. There is a known issue that has been reported to our QA team where the next button will not function properly when replacing the submit button to jump to the next scene. I don't have a time frame on a fix, but in the meantime you could use either of the following work arounds:

  • include the results slide in the same scene as the questions
  • or, add another blank slide following the last question slide with the next/previous buttons enabled and set to jump to next scene (slide in scene). 

I'll try to keep this thread updated if I hear further from our QA Team. 

Corrine Kuhl

Thank you Ashley.  For my projects where I just had all quiz questions in one scene, adding the Results Slide to the quiz scene worked fine.

I have some larger projects with multiple quiz scenes.  I've added results slides to 2 scenes where there are quiz questions, and edited the results so only the quiz questions in the scene are calculated in the score.  In each case, I've enabled the Review Quiz option.  Then I added a Final Quiz Results slide (in a scene with no quiz questions) to calculate the total score & allow the user to Retake the quizzes if they want.  I'm having one issue.

On the second quiz results slide (in the 2nd quiz scene), I checked the "Show User's Score" and saved it, but it didn't show the score when I went through the module.  When I go back in, the option is unchecked, and it won't allow me to save that option.  While the user's score doesn't display on the quiz results slide, it does accurately show either a pass/fail message (set at 80% for pass).

The good news is that the final quiz score on the final quiz results slide is accurate & the combined score of both quizzes is displayed.  i took out branching and review branching slides, so each quiz scene is just the quiz questions and results slide.

Any ideas?  it's a pretty large file...if you'd like to take a look, is there a way I can privately upload a file?  Thanks in advance,

Ashley Terwilliger-Pollard

Hi Corinne,

It sounds odd that just the one quiz slide isn't displaying the score, but is showing you the pass or fail layer, and is showing you the correct score on the final results slide. It seems only connected to that one results slide, so first I'd try recreating it in a new scene to see if the behavior persists or importing the project into a new Storyline file to resolve any unusual issues. 

If you'd like to share it privately there are a few ways to send it, you can share it here with our Support team and let me know the case number so that I can follow along. You could also upload the .story file to a public Dropbox folder and share the link here or in a private message, or use a site such as WeTransfer.com to create a download link that you could share as well. 

Sarah Burgess

<3 !!! I was searching all over for why my results slide wouldn't come up!  Didn't know there was an issue with having it in a separate scene (since the options are the same for selecting the question draws!).  You rock!  Thanks for saving me another 30 mins of repeated-head-into-desk.  

Teresa Scanlon

I'm having a real challenge with my quiz results. First, I had the same problem as described above- my "Next" button went nowhere after "Review Quiz". I finally got so frustrated that I just removed the "Review Quiz" button altogether. I had tried all of the suggestions above and nothing worked. Now, after I've removed the "Review Quiz" button, my Success and Failure layers will not appear on the results slide. Goodness, this is frustrating. Please help.

Wendy Farmer

Hi Teresa

I've tried to open your file but each time I do it shutdowns Storyline. Not sure if there is a corrupt slide that could be causing you issue. I'll try and create a new file and import your slides in to see if anything changes.

Update: When I imported your file into a new file the slides appeared like this - only the first slide (not quiz slide) had any formatting applied - wondering if your master slide layouts may be corrupt (if you are using masters).

Wendy Farmer

Hi Teresa

I renamed your story file, inserted a new result slide which should have automatically created a new set of 4 result variables but it didn't.

I then deleted all result slides, saved the file, reopened, created a new result slide - same results - the layers don't appear.

I deleted the success/fail layers then recreated them - same result the layers never appear.

I would be logging a support ticket to see if the Articulate guys can help you.

Sorry I couldn't be more help.

Leslie McKerchie

Well that's never fun Teresa, but thanks for popping back in with an update.

For future reference (although I hope it never happens to you again), there may still be a working version of your project in your temp files. Here's how to check: 

1) Open this folder in Windows Explorer: %appdata%\Articulate\Storyline 

2) Scan the contents of this folder for a file that starts with the name of your project. If you find one, copy it to your desktop. If you find more than one, copy the latest version to your desktop. 

3) Change the file extension of the copy on your desktop from *.tmp to *.story. 

4) Double-click the file to open it in Storyline. 

File corruption is unpredictable, and there's no straightforward way to determine what causes it. Common causes are environmental (disk errors, power outages, improper shutdowns), viruses, failed Windows updates, and even file size (i.e., very large files have a higher risk of corrupting). Consider using the preventative measures described in this article to protect your project files.

LaVon Bowman

I have the same issue with the Next button on the Results slide. So...

I created Variable "Change of state of NextButton To State Normal When Variable changes Variable "NextButton"

Then I created a Trigger NextButton 
Change the state of NextButton "Next" to Normal 
If Results.ScorePercent is Greater than or equal to Results.PassPoints

This does not work. I am attaching a screen capture of the above.