Safari not respecting player settings in some circumstances

Hi,

I just noticed this new bug in build 3.14.15225.0.

As you may know, in Safari 11 (desktop), Apple has changed the way videos are handled. So Articulate has had to put a workaround in place to deal with this. 

In short, if you have a video on the first slide of your course, learners will have to hit a big silver play button before the course will start.

The play button looks like this:

big silver play button

Note that this only appears in Safari 11, if there is a video on the first slide, and if you haven't clicked on anything in the course (e.g. if you say 'no' to the 'would you like to resume?' message this won't appear, as you've clicked something in the course).

The problem is that when this play button appears, it also adds a player border that shouldn't be there. I nearly always use a chromeless player. So a slide should look like this:

Chromeless player on light grey background

However, after the above Play button appears, it looks like this:

dark grey border around slide

I've raised this with support (#01321897) but thought I'd share details here in case anyone else runs into this issue.

17 Replies
Leslie McKerchie

Hey Steve and welcome to E-Learning Heroes :)

I'm not sure I'm following what you are reporting here.

Matthew's issue above was specific to the chromeless player.

Sounds like you are having an issue with your videos playing in Chrome 66? We are investigating a few issues. If you could reach out and share your .story file with our team here, that would be very helpful.

Ashley Terwilliger

Hi Sebastjan,

Thanks for posting here, and as Leslie mentioned this is specific to a course with a Chromeless player displays that now displays a grey border when viewed using Safari browser. It sounds like you're seeing this in Firefox and Chrome, and not necessarily Safari? If so, I'd love to take a look. Can you share a copy of your .story file here with us and a link to the course? 

The play button is expected in Chrome based on their changes to autoplay (for video and audio), and the Firefox play button is something our team is checking into as we've yet to hear that they implemented any autoplay policies. 

Matthew Bibby

Has there been any movement with this? HTML5 output in desktop Safari still has this border applied after the autoplay button is pressed.

It's been four months since this was brought to your attention... surely it's a relatively easy fix?

Using latest version of SL360 and the latest version of Safari.

Support case (#01321897).

Ashley Terwilliger

Hi Matthew,

This is still one our team is looking into, so sadly I don't have an update yet. I do see in their testing it was determined that this only existed in the Classic player. The modern player doesn't show the same border when choosing to off menus and controls. 

We'll let you know here as soon as we can about this one, and let me know if you're seeing something different in the modern player.

Matthew Bibby

Thanks for the reply Ashley. Yes, this issue does only exist in the Classic player.

I'd happily switch over to the Modern player but as I still have clients who rely on Flash and use older versions of IE, this isn't an option.

Unfortunately, as you know, large government and corporate clients can be a bit slow on making changes like ditching Flash and moving to a modern browser... so I'll likely be using the Classic player until 2020. 

Ashley Terwilliger

Do I ever...I talked to a government customer the other day who was still using Presenter 5...😬

But, the issue we have reported here was specific to the HTML5 output in Safari (and Chrome for K Cooper), so it shouldn't be impacting your users who are viewing the Flash output in IE. Hopefully, that's some solace while our team keeps digging into this! 

Matthew Bibby
Ashley Terwilliger

Do I ever...I talked to a government customer the other day who was still using Presenter 5...😬

But, the issue we have reported here was specific to the HTML5 output in Safari (and Chrome for K Cooper), so it shouldn't be impacting your users who are viewing the Flash output in IE. Hopefully, that's some solace while our team keeps digging into this! 

Presenter 5? 🤣. I once had a client whose call centre ran entirely on a modified version of DOS and needed specific hardware to run. So most of this managers time was spent on eBay looking for these old computers that they could get parts from... 

The issue is that while we need to support Flash in IE, many people are completing the training on laptops or home computers using other browsers so they are coming across this issue.

And it looks pretty crummy.

I'm sure you can appreciate how frustrating it is when stuff like this that dramatically impacts the quality of our published courses, yet there is nothing that we can do to fix it.

It's embarrassing to explain to a client why this is happening... and that the bug has been with Articulate for over 4 months and still hasn't been resolved. I don't know how complicated it is to fix,  but I can't see how it would be a major job.

Thanks for listening Ashley.

Katie Gokhshteyn

Hi, all. I'm really excited to let you all know that we just released update 19 for Storyline 360; check out the release notes here! 🎁

We've got a solution for the issue where the chromeless player would display a grey border when viewing the HTML5 output in Safari. Thanks again for bringing this to our attention, folks!

Here’s how you can update Storyline 360 to see everything the latest release has to offer. Let us know what you think!