Scorm 1.2 upload to LMS issue

Feb 06, 2015

Hi All

I've posted the message below to the Moodle communicate, but thought it would be a good idea to also post it here. Any help will be much appreciated.

Moodle forum message:

I am also getting this error message "Can not create local file pool file, please verify permissions in dataroot and available disk space".

I am trying to upload a scorm 1.2 file of 24mb. When I click save I get the error message.

I have done the following trouble shooting:

We are using Moolde 2.6.2 - I've tried uploading the scorm to other activities to try and figure out if the problem is on Moodle. Also created a new course to see if it's not perhaps something wrong with my course. Unfortunately no success. I then used the same activity to upload a scorm file I know works ; this was successful. So now I now it's something with the scorm file.
I am also able to load a much larger scorm file to our site without issues.
We are using Articulate Storyline 2. I've asked the author to re-publish the file as in previous case this worked. Unfortunately not this time.
I then asked another author to re-publish - same results
Went on like this with another 3 authors - same results
So now I started thinking it's the source file...
Then asked someone outside of our company with Articulate 2 to also publish the file (same source file) ; This file I was able to successfully upload.
I then downloaded I Articulate trial version on my home pc and published again - I was also able to successfully upload this file.
So now it's safe to say that when publishing from Articulate with our standard issue computers and build (software), the publishing is not working.
I can also see that the file size is exactly the same when publishing from my company computer and from my home pc.
Any ideas of where the problem could be.


3 Replies
Dan Marsden

Could be an issue with the version of Moodle you are using. 2.6.2 is quite old and there are some very major security issues that have been fixed recently - you should upgrade to 2.6.8 ASAP

Older versions of Moodle had an issue on certain types of hosting where the file-locking didn't work quite correctly - I'd suggest upgrading to fix the security issues and then you may find the file pool issues have been fixed as well.

This discussion is closed. You can start a new discussion or contact Articulate Support.