SCORM error with Storyline

i created a quiz in Storyline and packaged it for SCORM 1.2. I tried uploading the zip to Moodle and to SCORM Cloud. Both give error messages. Moodle just shows "XML error: Invalid character at line 9" and Cloud says 

"Course import failed, error was: Error opening the manifest file. Could not load manifest from-/courses/05NMM54VUZ/pharmaquiz2292875b-95d2-4d4e-9ef8-7f6f1d5388e5/0/imsmanifest.xml Possible causes of this problem include a bad file location, insufficient permissions, or an invalid XML document (check for un-encoded special XML characters such as & > &lt. The specific error message is: An invalid XML character (Unicode: 0x1f) was found in the element content of the document."

Funny because other SCORM packages upload fine. Here are the setting I used:

http://screencast.com/t/muMMqSlloe

http://screencast.com/t/vdn79ozSFl0

http://screencast.com/t/bKV1Iv5pKLZ

Thanks for any help because I am LOST. ;)

15 Replies
Jena Lawing

Hi Steve, 

I'm part of the SCORM Cloud team over at Rustici Software and I think I may have a suggestion to help you out. This error is showing up in SCORM Cloud due to an error in your manifest file. The best place for you to start is to see if there are any errors when you open your manifest file in an HTML editor.

If you need a little more help figuring this out, shoot us an email at support@scorm.com and we will do our best to help work through this with you. 

Thanks!

--

Jena 

Carl Utter

Hi Steve,

Not sure if you are still experiencing an issue or not. I wanted to add that many times when I experience an "Invalid Character type" error I have found that it is because the IDE I was using when creating or editing my files was configured for an incorrect Line Break type for the server where the files were hosted.

As an Example:

  • If using Adobe Dreamweaver (5.5), you can set the Line Break type @ Edit -> Preferences -> Code Format (select from drop-list)
  • More times than not when I check this it has been set to Windows (CR LF) format when I needed it to instead be a Unix  (LF) format
Stephen L. Colucci, Ph.d.

Thanks for all your help! i'm still seeing the same problem after trying your suggestions. One again I am using Articulate Storyline to develop courses and quizzes, and also publish to SCORM 1.2. It works fine if there is no attempt to communicate with the LMS, but that is precisely I need it to do for quiz results. :/

This is the first release, so i would expect some bugs, but the inability to report scores seems hard to overlook in beta, so i assume it's me.

Will Findlay

I don't know that I agree it is your fault... Maybe it is the version of Moodle you are using? Although it seems you wouldn't have also had a problem with the SCORM Cloud server.

After you produced the Storyline file, did you use Storyline's built-in zip function to zip it up before uploading to Moodle? This is what I did and it worked. I was thinking maybe you used a different zip tool?

Thomas Smith

I vaguely recall a similar problem with docebo 3.6 where I was getting the error upload message.  I had to change something in the configuration to fix it.  I think I found the fix in http://www.elearningcommunity.net/forum/index.php but it may have been the older original docebo community.

Its a pity that this great LMS has gone private as while it was a bit clunky it was one of the best LMS's I have used for corporate training.

Regards

Thomas

Christopher Robinson-Keys

I experienced the same error message last night.  Decided to sleep on it and came back with fresh eyes this morning.   After a few more failed attempts I realized that when I was publishing the course, I had left my selection on "Web", not "LMS".   In case anyone else experiences the same error messages, it never hurts to double check your publish setting.