SCORM not sending quiz score to LMS

Any help would be appreciated for the following problem:

SCORMs created in Storyline (current trial version) are running beautifully in my LMS (called SimplyDigi) but the actual score of a quiz is not being passed. Obviously, I am either setting something wrong in my publishing choices, or the LMS is not picking up the score. 

I have tried all four settings in the publishing output.

Also switched up browsers.

Windows 7 under IE and Chrome.

Here is what the LMS tells me when I exit the SCORM after deliberately passing the quiz at the end (I don't see anything about the actual quiz score):

01.24.2013: 8:15:09 AM PST

API Call:LMSFinish("")

API Returned:true

title:Test10

lesson_status:passed

entry:resume

exit:normal

total_time:00:09:43.97

session_time:0000:00:00.00

suspend_data:235i4080a0905060b0c070SR1001811J01011011110121101311014110151101611017110181100~2P3~221a9101001a1a3aP0j2AgfDg30118_defaultqn02pife720118_default000000010~221a9101001a1a3uE0j2AgfDg30118_defaultqn02apfe720118_default000000010~2y1a9101001a1a38e1PjDi3000H0118_default6Ai00126Ai00m16Ai00I26Ai00n32Agqo035F0fe720118_default000000100

lesson_location:

launch_data:

PageURL: /CoursesDev/b5f8372e65b511e29ab6842b2b0cf817/index_lms.html

interactions._count:0

Seconds since last server call: 0

SCO Marked Failed: false

SCO Marked Passed: true

SCO Marked Completed: false

--------------------------------------------------------------------------------

Call Stack Window   Show Return Value  

Back 

  Next 

  Reload 

    Print 

  Outline 

  Exit 

15 Replies
Peter Anderson

Hey John, welcome to Heroes!

Would you mind testing your course in SCORM Cloud to help us determine if the issue is Articulate-related or if it's on your LMS's side? If it appears in SCORM Cloud as well, we'd be happy to take a closer look at what might be going on. If you can't replicate the issue in SCORM Cloud, it's probably an issue that you'd want to take to your LMS team. The articles here and here may also help clear up common LMS issues.

Thanks!

John Donohue

no good in stormcloud. Yes, I am getting "Congratulations, your manifest looks great!" but the results are the same if I pass the quiz or don't pass it and I don't see where it is passing my actual score, which was 100% when deliberately passing and 66% when deliberately failing.

log:

http://cloud.scorm.com/sc/guest/ViewDebugLog?logId=b2207c50-4a49-44b3-af59-c3f1a0455554&courseTitle=How+To+Boil+Water

- [09:49:18.228] LMSFinish('') returned 'true' in 0.002 seconds
[09:49:18.228] Checking for Finish Error
[09:49:18.228] Call is error free.
[09:49:18.229] Close Out Session
[09:49:18.229] Mode = normal
[09:49:18.229] Credit = credit
[09:49:18.229] CompletionStatus = completed
[09:49:18.229] SuccessStatus = passed
[09:49:18.229] MasteryScore = 80
[09:49:18.229] Score = null
[09:49:18.229] Sco was taken for credit
[09:49:18.229] Sco is completed so resetting credit to no-credit and mode to review
[09:49:18.229] Next entry is normal
[09:49:18.229] Session Time: PT26.62S (2662 hundredths)
[09:49:18.229] Previous Time: PT0H0M0S (0 hundredths)
[09:49:18.229] New Total Time: PT26.62S (2662 hundredths)
[09:49:18.230] New Tracked Total Time: PT28.57S
- [09:49:18.230] Pre-evaluation of exit action
[09:49:18.230] Using finalScoCourseSatisfiedSuspendExitAction parameter
- [09:49:18.884] OverallSequencingProcess for SCORM 1.1 / SCORM 1.2
[09:49:18.884] Transferring RTE data to Activity data
[09:49:18.885] Rolling up activity data
[09:49:18.885] Checking for first SCO pretest
[09:49:18.885] Using finalScoCourseSatisfiedSuspendExitAction parameter
[09:49:18.885] No API Runtime Nav Request, exit action=exit,no confirmation
Want 
Completion:
complete
Success:
passed 
John Donohue

Problem solved by me, and also tech support sent the answer just as I found it. This forum should be able to spot the trouble associated with "score not passing to LMS" pretty easily, however. Here is the solution:

1) Select Publish->LMS. Make sure that you set the LMSto SCORM 1.2 or 2004.

2) Select Reporting and Tracking... button.

3) On the Reporting tab, please try to remove any specialcharacters (example: exclamation point!) to the Title and Identifier.

4) Select the Tracking tab. Make sure that you set yourtracking to "Track using quiz result". 

5) Select Ok and publish button. 

My issue was that I never saw that "Track using quiz result" selection. I am new and probably moving a little too fast!

Thanks to tech support for responding to the issue. Solved.

Todd Coulson

Juanma pointed out the type of tracking that I am doing for all of our modules in Blackboard. 4 module project, one of those modules has this error, the others are all tracking correctly. I am using the track using number of slides viewed, because I only care about completion of all slides. We do have some interactions in our project which may be tricking the articulate file into thinking the piece should be "track using quiz". How can I verify this is the issue though? The log in Blackboard only says "OverallSequencingProcess for SCORM 1.1 / SCORM 1.2". Do I need to make sure all results are cleared before tracking based on number of slides viewed?

Ashley Terwilliger

Hi Todd and welcome to Heroes! 

So you're tracking each .story file by slides viewed - and one of those is not working correctly within Blackboard? Are you able to review the original .story file to see how it was set up to confirm that it wasn't inadvertently tracked by a quiz results slide? If you had previously uploaded the course and then made a change to the tracking requirements - it could still be referring to the older version. I'd suggest trying to publish the problematic .story file again and load it into Blackboard as a new course to see how it behaves. 

Todd Coulson

Thanks Ashley.

"So you're tracking each .story file by slides viewed - and one of those is not working correctly within Blackboard?"

Correct.

"Are you able to review the original .story file to see how it was set up to confirm that it wasn't inadvertently tracked by a quiz results slide?"

I checked the files we are working with all 4 modules are tracking "track using number of slides viewed"

I do think I figured out the problem though, there was a ":" in the title. Could this be the culprit? Is there any documentation surrounding acceptable characters for the title of the published item?

Senthilnathan S

Hi,

I also have an issue in updating cmi.core.session_time and cmi.core.total_time. I have a resource with few slides. My users have to read the slides any time. Based on the slides duration the time get updated in the session_time and finally stored in total_time.

If the user can read few slides only and went out the resource instead of reading all the slides. The partial time have to be updated in the database.

It is happening perfectly in other browsers like Firefox and IE, etc. But in Chrome(version 44.0) its not updating. Only when the user start to read slide from begin to end and complete the resource the time get updated in database. If partially read few slides, not updating the DB, it says 0000:00:00.

Why, is there any reason in Chrome browser???

Ashley Terwilliger

Hi Senthilnathan,

The time spent in the course is handled by the LMS, as Storyline doesn't track duration on a slide as a user may spend more time than the timeline allows or less depending on how you've set it up. If it's not behaving correctly in Chrome I'd advise confirming with your LMS team that it's a supported browser and also look at testing it in SCORM Cloud as it's an industry standard for LMS content.