SCORM not uploading in my LMS

Hi there,

I am having an issue with uploading SCORM into my LMS classes.

 

I have used the same settings as I always have to package the SCORM, but they are failing when I go through the process of uploading them.

 

This is the error message I am getting from the LMS:

An exception occurred during the import:

"\x82" from ASCII-8BIT to UTF-8

/home/edu20/shared/bundle/ruby/1.9.1/gems/htmlentities-4.3.1/lib/htmlentities/decoder.rb:26:in `encode'
/home/edu20/shared/bundle/ruby/1.9.1/gems/htmlentities-4.3.1/lib/htmlentities/decoder.rb:26:in `prepare'
/home/edu20/shared/bundle/ruby/1.9.1/gems/htmlentities-4.3.1/lib/htmlentities/decoder.rb:10:in `decode'
/home/edu20/shared/bundle/ruby/1.9.1/gems/htmlentities-4.3.1/lib/htmlentities.rb:44:in `decode'
/home/edu20/releases/20160520175536/app/models/blob.rb:102:in `create'
/home/edu20/releases/20160520175536/app/models/blob.rb:163:in `create!'
/home/edu20/releases/20160520175536/app/models/zip_util.rb:59:in `block (3 levels) in unzip'
/home/edu20/releases/20160520175536/app/models/zip_util.rb:21:in `fopen'
/home/edu20/releases/20160520175536/app/models/zip_util.rb:21:in `block (2 levels) in unzip'
/home/edu20/releases/20160520175536/app/models/zip_util.rb:16:in `times'
/home/edu20/releases/20160520175536/app/models/zip_util.rb:16:in `block in unzip'
/home/edu20/releases/20160520175536/app/models/zip_util.rb:12:in `open'
/home/edu20/releases/20160520175536/app/models/zip_util.rb:12:in `unzip'
/home/edu20/releases/20160520175536/app/models/import_scorm_job.rb:78:in `process_module'
/home/edu20/releases/20160520175536/app/models/import_scorm_section_job.rb:18:in `process_module'
/home/edu20/releases/20160520175536/app/models/import_scorm_job.rb:24:in `block in run'
/home/edu20/shared/bundle/ruby/1.9.1/gems/activerecord-3.0.20/lib/active_record/connection_adapters/abstract/database_statements.rb:139:in `transaction'
/home/edu20/shared/bundle/ruby/1.9.1/gems/activerecord-3.0.20/lib/active_record/transactions.rb:207:in `transaction'
/home/edu20/releases/20160520175536/app/models/import_scorm_job.rb:23:in `run'
(eval):3:in `block in run_with_newrelic_transaction_trace'
/home/edu20/shared/bundle/ruby/1.9.1/gems/newrelic_rpm-3.12.1.298/lib/new_relic/agent/instrumentation/controller_instrumentation.rb:361:in `perform_action_with_newrelic_trace'
(eval):2:in `run_with_newrelic_transaction_trace'
/home/edu20/releases/20160520175536/app/models/job_server.rb:140:in `run_job'
(eval):3:in `block in run_job_with_newrelic_transaction_trace'
/home/edu20/shared/bundle/ruby/1.9.1/gems/newrelic_rpm-3.12.1.298/lib/new_relic/agent/instrumentation/controller_instrumentation.rb:361:in `perform_action_with_newrelic_trace'
(eval):2:in `run_job_with_newrelic_transaction_trace'
/home/edu20/releases/20160520175536/app/models/job_server.rb:100:in `run'
script/run_jobs.rb:48:in `'

 

 

Can anyone help me please?

 

Cheers,
Megan 

3 Replies
Christie Pollick

Hi, Megan -- Thank you for reaching out and sorry to hear of your difficulties! May I ask if you have had a chance to also test your course to see how it loads onto the SCORM Cloud, as that is the recommended environment for LMS testing? Please also see this article for some important troubleshooting recommendations: How to Troubleshoot Your LMS with SCORM Cloud. If issues persist, let us know and we'll see what more we can do to assist! :)

Christie Pollick

Hi, Megan -- Thank you for following up, and typically, if your course functions correctly via SCORM Cloud but not in your LMS, we tend to recommend reaching out to your LMS directly for their input. Please feel free to follow up here and let us know the results of your contact with your LMS so that others may benefit, as well.