SCORM package not working in Chrome - Moodle

I'm having an issue of my lesson that I created in Articulate Storyline (SCORM 2004) is displaying correctly in Firefox but not Chrome. After reading some articles, I decided to switch the Articulate Storyline export SCORM settings so that I didn't select "Include HTML5 Input". That version totally worked on Chrome but now isn't working in Firefox.

Can someone help me figure out what I'm doing wrong?

25 Replies
Ali Goulet

Hey Kim!

Sorry you're running into those issues, that's definitely not what I'd expect to see. Have you tried uploading your course to SCORM Cloud to see if the same happens there? That'll give us a great idea of whether it's file related or Moodle specific. 

You're also welcome to share your project file here and I'm happy to do some testing with it. You can add it as an attachment right to a comment like this: 

Thanks for reaching out about this!

Kim Klasner

Thank you! I've attached the file. When I published for the LMS, I unclicked "HTML" and it worked in CHrome but now not in Firefox. I'll also spend some time using SCORM Cloud to test things out but if you could check out the attachment and see if you can figure out what I'm doing wrong, that would be great.

Ali Goulet

Hey Kim,

Thanks so much for sharing your file with me!

I published your course using these settings in Storyline 2 Update 12: 

I then uploaded it to SCORM Cloud to test it. I'm able to view the course in both the latest versions of Firefox and Chrome. 

Take a look at it here and let me know if you're seeing something different or if I've missed something! 

Mary Kuhn

Any updates on this? I'm also experiencing issues with a file I published to CSOD back in January 2017 (published out of SL2). End users are experiencing issues when they run the online training in a Chrome browser but not Mozilla or Internet Explorer. I did included HMTL5 output when I published to SCORM 2004. It seems there is a recent issue (last few months) with how Chrome handles these files. 

Ali Goulet

Hey Mary,

Sorry you're running into that! We didn't hear back from Kim here so I'm not sure if her issue was resolved.

I'm happy to help nail down the cause in your instance, though! Would you be able to share your unpublished .story project file here so I can do some testing with it? 

You can attach it right to a comment like this:

Thanks a bunch!

Rebecca Ogrady-Marshall

Hi, was there any follow up response for this?

I'm having problems with Scorm published Storyline 2, that I uploaded a year ago onto Moodle.  I've imported it into various courses and was working fine.

However, as of about 2 months ago has stopped working.

This has happened in a few different Scorm published Storyline 2's, that are uploaded onto Moodle 2.9.



Rebecca Ogrady-Marshall

Hi Alyssa, 

It is not working in Chrome, sometimes there is an error message, other times it just comes up blank.

It works on and off in explorer.  This is happening across most of our scorm packages (haven't tested them all).

Trying it just now it says Activity loading, then a blank page, after a few minutes the frame for the activity appears with a white screen inside the frame.  Another SCORM activity is coming up with a flat grey screen.

Previously is was saying a server error, but that isn't an issue now.

Storyline's published in other formats are working fine, and these were working until recently, they are the same files.


Thanks for your help!

Ashley Terwilliger

Hi Rebecca, 

Is this Storyline 2 or 360 (I ask as I saw another post here from you about using Storyline 360.)  When you do see the error message, what does it say?

I don't know a lot about Moodle, but I do know that Moodle 2.9 is back a couple versions. Could they have changed their supported browsers and outputs? You could test this out by uploading the troublesome content to another environment such as SCORM Cloud. 

Let us know if you're able to pin down the errors any further! 

Amy Mills

HI Everyone,

I think I'm in a similar situation. I published a SCORM 2004 3rd edition course and published it in our LMS (Cornerstone).

I'm finding that users are having some issues in CHROME (sliders not working, etc.) but switching to IE seems to work for them. The Chrome users are also having issues that I cannot always reproduce myself in Chrome.

Has anyone using Cornerstone tried to change the compatibility settings?

Rebecca Ogrady-Marshall

Hi Ashley, thanks for your help!

This is Storyline 2 when opened in Chrome.

Correct about Moodle 2.9 being back a few versions but it is still supported and these Scorm interactions were working 2 months ago, not in line with any Moodle update timeframes.  Our Moodle version has not been 'touched'.

The Scorm interactions are working on IE, but not on Chrome.  However, we recommend people use Chrome (or Firefox) for Moodle as in our area these browsers tend to be more suitable for current use.

Often there is no error message, it is just a blank square box where the interaction should be.  Sometimes grey, sometimes a white frame.

One of the packages, an earlier interaction that we've had on the site for at least 2 years, opens onto a grey resume page which doesn't have any ability to click/open anything, i.e. the next button and resume do not have any interactivity.  Screen shot below.


Any ideas?

Did Chrome update their settings and are not compatible anymore?

Amy Mills

Hi All,

So i think I'm a little stuck. The folks who are experiencing Chrome issues are using version 64- does that mean that the Articulate Chrome 44 updater would not help?

My Storyline 2 is updated with the latest version.

There have also been instances that the learners cannot reproduce. For example, a next button does not appear when the trigger should change it to visible. When the learner logs out and opens the course again, there is the Next Button. When I proxied as that user and launched the course in IE, the next button was there as expected.

I'm going to have to answer to our leadership before rolling this training out to over 5,000 employees and I'm so lost for even how to explain what might be happening because I don't know...

Should I turn off the HTML5 output (would that make the course un-usable for our Safari users)?

Should I try turning OFF compatibility modes in our LMS?


Rebecca Ogrady-Marshall

Hi Amy, I'm not sure how to help but hopefully the Articulate experts can.

From my end, we're upgrading our hosting and server speed and then looking back into these issues.

In the meantime we're asking people to be patient.

We have published a lot of interactions using the LMS publishing (for things that don't require grading and tracking is adequate on the LMS), which works smoothly on Chrome.  It is only the SCORM packages that aren't working completely.



Ashley Terwilliger

Hi Amy,

I'm sorry you're still struggling with this issue! If Chrome recently updated, I don't think the Updater for ver 44 would help in this instance, as that was for a very specific issue that popped up post ver 44 (which is some time ago now).

I do wonder if your LMS has specific settings you could change or turn off based on how it's responding inconsistently in Chrome and IE? Also do you know if your  learners have Flash enabled in their Chrome and IE browsers? Although Chrome is supported for Storyline 2 and HTML5, it could explain some of the oddities if Flash is disabled in the browser. 

Another option would be to take a look at how that same course behaves outside your Cornerstone environment. You could test uploading it to SCORM Cloud a standard for LMS testing, and then see if you can replicate the same issues there. 

Please feel free to keep us posted and let us know how else we can help! 

Enza Lilla

Hi All,

I also have the same problem with Chrome.

Firefox and Safari ok
I use chrome latest version and storyline 2, latest update.
I have a scorm with 5 quizzes and if I run again the whole scorm the second time does not propose all the quz but only a few.
I also tried it in the  SCORM Cloud and behaves the same way, but I do not understand the warnings (Parser Warnings)

 Can anyone help me, please?


Alyssa Gomez

Thanks for allowing me to test your file, Enza! I saw the same problem you were seeing. After a little digging, I found that this is a bug in Storyline 2.

This bug happens when all of the following are true:

  • Viewing the HTML5 output
  • The navigation is set to "restricted"
  • The feedback per question is turned off

You can get around this bug by turning on the feedback per question. 

I'm sorry this problem is slowing you down, and we'll keep you posted on any updates we receive. 

Rebecca Ogrady-Marshall


Thanks for the feedback.  In my instances, the Storylines were working fine for over a year regardless of settings.

I had even gone into the unpublished versions, republished them and uploaded to the Moodle LMS and they were showing the same errors.

However, we upgraded to Storyline 360, went through the original unpublished files, opened with 360, republished and loaded onto the LMS and they are now working in Chrome.

It took at lot of time and we also had to upgrade.

From this I believe that it is an error in Storyline 2 and Chrome that occurred about 4 months ago and hasn't been able to be fixed.

- I wonder how many other people are having this problem?

- I wonder if the same thing will eventually happen in Storyline 360, as there is no real diagnosis and therefore no way of preventing a similar error.



Enza Lilla

Hi Alyssa,

thank you for your reply.

I would, however, like to understand better:

  • "Feedback for question is turned off" --> In the individual exercises I set "Feedback = by Question". What else do I have to change?
  • "The navigation is set to be restricted" --> where is this property established?


Ashley Terwilliger

Hi Enza,

The restricted navigation is controlled from your Player settings (the button between Preview and Publish). 

The feedback option is on each individual question. It looks like Alyssa saw that the questions didn't have any feedback enabled. I saw that your course had the feedback enabled, but that you were using custom incorrect/correct feedback layers - so that may be why it recognized it as not having the feedback option.