Seek bar doesn't work well with video and animation

I imported a video to my Storyline and had a few items synced with the video. The seek bar of the player was also enabled.

The problem was that when I scrubbed back and forth on the seek bar, the animations and video were out of sync. Items appeared at the wrong timings.

Is there a way to work around this? I submitted my case for support, but thought maybe I should share this to see if there had been similar issues.

 

29 Replies
Leslie McKerchie

Hi all,

I wanted to provide an update here, as Storyline 2 Update 8 was just released, and included a number of fixes which you can see in the release notes available here. The item you all may be particularly interested in is how it fixed an issue where a video would no longer be synced with the slide's timeline after using the seekbar to scrub back and forth through the video. You can download the latest update here, and after downloading and installing the latest update you’ll want to republish any existing content to ensure that the updates and fixes are applied.

Let us know if you have any questions, either here or by reaching out to our Support Engineers directly.

Ashley Terwilliger

Hi Megan,

Are you seeing the video out of sync when scrubbing the seekbar while previewing or viewing the published course, or are you seeing this while using the slide timeline preview button, or when scrubbing the video seekbar? 

Is there anything else on this slide besides a video? If you'd like to share a copy of the .story file I can also take a look! 

Megan Creegan

It's happening in the preview AND the published version when I scrub the timeline seekbar (located in the player). There are graphics on the slide as well, but that's all. It's happening on all my videos.

Unfortunately, I'm not able to share my .story file since it contains proprietary information. Am I the only person reporting this issue?

Alyssa Gomez

Hi Megan,

I've tried recreating this problem in a new Storyline 360 file, but I still need your help. I know you mentioned you couldn't share your file publicly, but could you send it to us privately here? Our team can even sign a NDA, if you'd like. 

If you do decide to open a case, let us know the case number so we can follow along!

Leslie McKerchie

Hello Hassaan,

Sorry to hear that you've run into an issue with your project.

The issue for SL2 was corrected.

I see that Megan shared an issue with SL360, so I took a look at her case and it seems that it was more of a design issue with the timeline and it's items being a different length than the video. Once these matched up, it all worked as designed.

Would you be able to share your .story file so that we can take a look? If you cannot share it here in the forums, you are welcome to share here privately.

Hassaan Ijazuddin

Hi Alyssa and Leslie,

Thanks for your replies. I checked the duration of my video and adjusted the slide timeline to make it same as video duration. The issues seems to be fixed now on local machine.

When I upload it on our LMS (on cloud) or even when on Articulate Online, and then scrub the timeline, video restarts losing it's synchronization with the timeline. I'll share the link and file privately. Thanks

Crystal Horn

Hey everyone! I'm excited to let you know that we just released update 24 for Storyline 360! It includes new features and fixes - check them all out here.

One of the fixes addresses an issue where clicking the video control seekbar was restarting the video instead of scrubbing in HTML5 output.  

Here’s how you can update Storyline 360 to take advantage of everything the latest release has to offer. Let me know how you make out!