Seekbar control

Apr 07, 2016

Hi, again. Here's a weird question. Is it possible to allow the user to drag the seekbar back after the timeline is complete, but not allow it until the timeline is complete? And is there a way to decouple the replay/rewind button from the seekbar? Thanks, as always...

12 Replies
Bobbi Bailey
  1. Create your .story project with the seekbar visible.
  2. Publish your .story project. Go ahead and “zip” if the course will be uploaded to an LMS.
    In the “publish successful” pop-up window, click “OPEN” to open the Storyline output directory.
  3. Double-click and open the story_content folder.
  4. Open the frame.xml file (this can be opened with Notepad)
  5. Find and replace the following:

    <option name="seekbar" value="true">


    <option name="seekbar" value="false">
  6. Find and replace the following:

    <control name="seekbar" enabled="true" />


    <control name="seekbar" enabled="false" />
  7. Save and close the frame.xml file.
  8. Launch and play your course. The seekbar should be hidden, but the replay button will be visible.

If uploading to an LMS, you have a couple more steps.

  1. In the file directory, right-click and "copy" the modified frame.xml file.
  2. Navigate to the story_content folder in the ZIPPED file.
  3. Right-click and "paste" (replace) the modified file here. You can now upload to your LMS.
Bobbi Bailey

Thanks!  Glad it worked for you.  As far as the .zip, it really does not matter.  You can zip the contents afterwards, just make sure you zip the whole storyline output folder.

If you want to get frisky with this :-) - you can do the reverse of the above (remove the replay button and show only the seekbar).  The search/replace items would be:

<option name="replay" value="true" />
<option name="replay" value="false" />

<control name="replay" enabled="true" />
<control name="replay" enabled="false" />

Joe Boss


Does anyone happen to know what the equivalent changes are for Storyline 3?  Recently upgraded and the old tweaks don't seem to have the same effect.

 We're looking to use HTML5 output rather than Flash, and that seems to be the reason it no longer works.

I also tried to modify the same settings in Frame.js and Frame.json to no avail.


This discussion is closed. You can start a new discussion or contact Articulate Support.